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Terms And Conditions Of Use 
These terms and conditions are divided into the following parts: 

 (A) a disclaimer of liability; 

 (B) terms and conditions governing the use of this User Manual; 

By using our User Manual, you accept these terms and conditions in full. If you disagree with these terms and 
conditions or any part of these terms and conditions, you must not use our User Manual.  

Exclusion Of Warranties, Representations And Guarantees 

We do not warrant, represent or guarantee: 

 the accuracy of the information published on this User Manual; 

 the completeness of the information published on this User Manual; 

 that the information published on this User Manual is up-to-date; 

 or the information in the User Manual can be applied to achieve any particular result. 

To the maximum extent permitted by applicable law we exclude all representations, warranties and guarantees 
relating to this User Manual and the use of this User Manual (including, without limitation, any warranties implied 
by law of satisfactory quality, fitness for purpose and/or the use of reasonable care and skill). 

To the extent that the User Manual and the information and services on the User Manual are provided free-of-
charge, we will not be liable for any loss or damage of any nature. 

We will not be liable to you in respect of any losses arising out of any event or events beyond our reasonable 
control. 

We will not be liable to you in respect of any business losses. 

We will not be liable to you in respect of any loss of or damage to profits, income, revenue, or anticipated 
savings. 

We will not be liable to you in respect of any loss of use or production. 

We will not be liable to you in respect of any loss of management time or office time. 

We will not be liable to you in respect of any loss of business, contracts, commercial opportunities or goodwill. 

We will not be liable to you in respect of any loss or corruption of any data, database or software. 

We will not be liable to you in respect of any special, indirect or consequential loss or damage. 

User Manual Availability 

We do not commit to ensuring that the User Manual will be available at any particular time. 

Furthermore, we do not commit to ensure that the User Manual will continue to be published in the future. 
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Licence To Use User Manual 

Unless otherwise stated, we or our licensors own the intellectual property rights in the User Manual and material 
on the User Manual. Subject to the license below, all these intellectual property rights are reserved. 

You may view, download for caching purposes only, and print pages from the User Manual for your own 
personal use, subject to the restrictions set out below and elsewhere in these terms and conditions of use. You 
must not: (a) republish material from this User Manual (including republication on another User Manual); (b) sell, 
rent or sub-license material from the User Manual; (c) show any material from the User Manual in public; (d) 
reproduce, duplicate, copy or otherwise exploit material on our User Manual for a commercial purpose; (e) edit 
or otherwise modify any material on the User Manual; or (f) redistribute material from this User Manual, except 
for content specifically and expressly made available for redistribution (such as our Website forum). 

Where content is specifically made available for redistribution, it may only be redistributed within your 
organization. 

Acceptable Use 

You must not use our User Manual in any way that which is unlawful, illegal, fraudulent or harmful, or in 
connection with any unlawful, illegal, fraudulent or harmful purpose or activity. You must not use our User 
Manual to copy, store, host, transmit, send, use, publish or distribute any material which consists of (or is linked 
to) any spyware, computer virus, Trojan horse, worm, keystroke logger, rootkit or other malicious computer 
software. You must not conduct any systematic or automated data collection activities (including without 
limitation scraping, data mining, data extraction and data harvesting) on or in relation to our User Manual without 
our express written consent. You must not use our User Manual to transmit or send unsolicited commercial 
communication. You must not use our User Manual for any purposes related to marketing without our express 
written consent. 

Third Party Websites 

Our User Manual includes hyperlinks to other websites owned and operated by third parties. These links are not 
recommendations. We have no control over the contents of third party websites, and we accept no responsibility 
for them or for any loss or damage that may arise from your use of them. 

Law And Jurisdiction 

These terms and conditions will be governed by and construed in accordance with Canadian law, and any 
disputes relating to these terms and conditions will be subject to the exclusive jurisdiction of the courts of 
Canada. 
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Chapter 1 Overview 
1.0 Conventions And Layout 
When the verb “Click” is used, it means “Left Click” if a Right Click is needed it will say “Right Click”. 

Many of the commands are written using the format; click on menu [Menu Item Header] -> [sub menu] -> [sub, 

sub menu- if needed] 

This means that you should click on the; menu bar along the screen top [with the heading] -> [then, click on 

the sub menu] -> [then, click on the sub, sub menu-if needed]. 

An example would be:  

Click on menu [Config(S)] -> [Page Setting]. This means that on the menu bar you should click on the text that 

says “Config(S)” and then click on the line that says “Page Setting”.  

In the “Config(S)” heading above, the (S) indicates a shortcut key. If you press and hold the Alt key and press 

the S key, that will give the same result as if you clicked on “Config(S)”. 

This manual is laid out in four chapters plus an appendix. Each chapter has many sections that are 

numbered in the following manner. x.x.x.x (where x is a number) the first number is the Chapter 

Number, the second number is a Topic, and any further numbers indicate greater depth within that 

topic. 

We will use the term “LCD” as a substitute for “Digital Control Unit” or HMI “Human Machine Interface” 

when speaking about saving and memory allocation as well as Data entry. The LCD is the interface to 

the Control Unit as it is both a keyboard and a display. The LCD is not the control unit, much like a 

keyboard and monitor are not a computer, however they both are used to supply access to the 

computer. 

1.1 Laser Engraving And Cutting System Introduction 
The Laser Engraving and Cutting System uses computer numerical control machine tools to achieve 

effective control, according to the user’s different design. 

The system includes the control board and control panel LCD, and supporting software. This manual 

describes how to use the software to complete the task of laser processing.  

A separate manual on hardware setup is planned. 

1.2 Software Supported Import File Formats 
Vector format: dxf, ai, plt, dst, dsb, eps, etc. 

Bitmap format: bmp, jpg, gif, png, mng, etc. 

1.2.1 Software Supported Export File Formats 
Vector format: ai and plt 
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1.3 Computer Requirements 
The following recommendation represents the minimum requirements. When using a more powerful 

computer the graphics are generated and displayed faster and the computing times and the data 

transfer to the laser are reduced. To use a newer software version, you may have to meet other 

requirements. 

 Windows 10, Windows 8/8.1. Windows 7,  Windows Vista  (with Service Pack 1 or later) and 
Windows XP  (with Service Pack 2 or later)  

 1024 MB of RAM, 400 MB of hard disk space 

 Pentium® 3 or 4 processor or AMD Athlon™ 

 1024 x 768 or better monitor resolution 

 1 free USB port,  

 Mouse 

 a supported RUIDA controller in the Laser 

IMPORTANT NOTES:  

1).This manual covers Version 8.01.19. If you cannot find a feature or function, check that you have 

Version 8.01.19 or newer. Click on HELP | ABOUT RDCam Top Line) view the bottom left corner for 

version number. If certain Shortcuts do not work as you think they should, download and install the 

“other language files” from RDWorksLab.com.  

Please Note: RUIDA's English files have many errors.  

Many of the screen grabs in this manual are done with the “Other_lang.ini” (Other Language) file in 

use. The original names are used for the menus with the (Other Language words) in ellipses. The 

English language files that come with RDWorks contain many errors.  An additional set of language 

files with corrected English references has been prepared by the authors.  They can be installed and 

accessed as an "Other" language file.  This corrected set of files and instructions for installing them 

are available for download by registered members of http://rdworkslab.com/ at 

(http://rdworkslab.com/viewtopic.php?f=45&t=517). The shortcuts and screenshots used in this 

manual are based on these "Other" language files." They may also be included with the manual 

distribution. 

We will be using the phrase “LCD” for the Machine Display Panel. It means “Liquid Crystal Display”, 

and is a common term in industry. Also, HMI is another phrase that is common in industry for the LCD 

control panel. It means “Human Machine Interface”. 

Passwords: There are several passwords used by RDWorks. They are RD8888. 

Using these next two on the LCD can cause your settings to be corrupted.  

Set fact para HF8888 and ESPECIALLY Def fact para – CC8888 & possibly GXFC88. 

The laser uses heat to cut and engrave. There have been MANY reports of fires in the laser. 

Please keep a powder fire extinguisher handy and do not leave your machine operating while 

you are not in attendance. It only takes 10 seconds for a fire to get out of control. 
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1.4 How To Get Your Machine To Speak English 
When many of you get your machine, it will be speaking Chinese. If you don't understand Chinese, 

this can be a real problem! 

I'll guess you don't understand Chinese, so here is a numerical method to teach your Laser to speak 

English:  

1. Power up your Laser.  

2. Call up the Menu on the machine by pressing the Z/U button, in between the 4 directional arrows.  

3. Press the DOWN ARROW key 9 times to get to the TOP of the Menu on the Right Hand Side.  

4. Press the Enter key.  

5. Press the Down Arrow key 2 times so the third item down is highlighted,  

6. Press the Enter key.  

For the video https://www.youtube.com/watch?v=UF37pbL2hpw  

You should now have English. There are other choices for Language, so if you want another language 

select your desired language.   

For pictures go to http: //rdworkslab.com/viewtopic.php?f=27&t=187 . 

1.5 How To Teach The Software To Speak English 
In addition to selecting the Language in the installation process, to set the software language you can 

easily switch to a different language within the software. 

Click on menu Bar [Help] -> [Language] (7th from the left then down 3) and expand the menu, then 

select the desired language. The third one down is English. In this manual, we are using the Other 

Language file from RDWorksLab.com. It is the 4th selection if you have downloaded the corrected 

“Other Language” files. 

See Section 2.2 Language settings for graphics. 

1.6 IMPORTANT – Make Backups!! 
You have your new machine and it speaks English, so what's next? 

The first thing you need to do is to hook up the computer to your machine. 

Once that has been accomplished, you need to make a Backup of your machine settings. Should you 

have troubles in the future, it will be VERY HANDY to have a backup. Watch BOTH OF THESE videos 

for complete instructions.  

RDWorks Learning Lab #74 https://www.youtube.com/watch?v=h9NCqTT3Sh8 as well as RDWorks 

Learning Lab #77 https://www.youtube.com/watch?v=Y-tva0CSJao  

See Section 3.3 for instructions on saving the USER “Original.RDUSet file. 
See Section 4.11 for instructions on saving the “Original.RDVSet” file. 
See Section 4.11.4 for instructions on clearing initially corrupt “Running Data”. 
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IMPORTANT NOTE: If your user settings have been changed by you and you are happy with the 

results, you would be advised to SAVE your current settings to the machine, then Read and Save 

them to your computer as your working backup settings. 

1.7 HOT KEYS 
Press and Hold the Alt key while pressing the letter after Alt 
Alt + Letter 

Alt - F  to select the Files Menu 
Alt - E  to select the Edit Menu 
Alt - D   to select the Draw Menu 
Alt - S   to select the Configuration Menu 
Alt - W   to select the Handle Menu 
Alt - V   to select the View Menu 
Alt - H   to select the Help Menu 
Alt - M   to select the Model Menu 
Alt - T  to select the Tool Menu 
Press and Hold the Control (Ctrl) key while pressing the letter after Ctrl 
Control + Letter 

Ctrl - A   to select All objects 
Ctrl - C  for Copy 
Ctrl - E   for Export 
Ctrl - I    for Import 
Ctrl - N  for New File 
Ctrl - O  for Open .rld files 
Ctrl - S  for Save 
Ctrl - V  for Paste 
Ctrl - X  for Cut 
Ctrl - Y  for Redo 
Ctrl - Z  for Undo 
Press Ctrl and Roll Mouse Wheel to Zoom In or Out at the cursor's location 

Press and Hold the Control (Ctrl) key while pressing the Number after Ctrl 
Control + Number 

Ctrl - 1  Draw Straight Line 
Ctrl - 2  Draw Polygon/Polylines 
Ctrl - 3  Draw Curves 
Ctrl - 4  Draw Rectangles  
Ctrl - 5  Draw Ellipses 
Ctrl - 6  Draw Text  
Ctrl - 7  Draw Point  
Ctrl - 8  Twain Import / Capture  
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Figure 1 

 

1.8 Tips – Tricks & Terminology 
Objects that are grouped are cut together - grouped inside objects will cut first if they were selected 

first, then outside objects will be cut. 

Setting the background color to a light gray helps with seeing 

lighter colored layers. 

By default, files import to the center of the work area. The 

import position can be set by clicking on menu [Config(S)] -> 

[Config File Parameter Setting] and selecting the desired 

position (Figure 1). 

Once imported, it may be easier to use Ctrl-X to cut, then use 

Ctrl-V to paste, which will place it centered on where your 

cursor is currently located. 

Text remains editable until you select the Un-group Icon - near Top Right on the Toolbar. 

GO (and GO Scale) refers to the frame function to check out boundaries. 

Capture is used to acquire a scan from a Twain Scanner (if installed). 

Feed Param (Parameters) are for a machine with a conveyor type belt table. 

When saving files to a USB Stick/Thumb Drive for use on the machine, you need to use the 

"SavetoUFile" button, so it is saved as an ".rd” type file and not as a .rld file. When a USB or Ethernet 

cable is attached from a computer to the Laser, then simply click on "Download” and enter an 8-

character or less filename. If you try using a Stick/Thumb Drive with RLD files and NOT using RD files 

you will fail as only RD files can be seen using the Stick/Thumb Drive. 

Memory can be overloaded by leaving too many files on the Laser LCD. There is a maximum of 100 

files. See Section 3.4 on how to Delete All files in the LCD.  

If the images on the LCD are reversed, they can be fixed using the LCD Panel on the machine. Press 

the Z/U button, then press up twice to select the option "Screen origin+", and press Enter. The default 

option seems to be Top Left, change it to Top Right. Your files should now display correctly. If they 

print reversed, then see Section 3.1 

"No enough extend space."  ERROR - at the end of each sweep the beam switches off but the head 

has to travel on as it decelerates to a stop, turn around and accelerate back up to speed before 

turning the beam on again. If you have set your program to run from 0, 0 or a point that does not allow 

this to happen, this overrun will go outside the allowable work area. You need to leave about 5mm all 

round when engraving to allow for this, depending on speed. So set your origin at 5, 5 and make sure 

your image is not bigger than 10 mm less than your work area. Try moving it off 0, 0 by about 5 mm's 

in both axis settings, hit origin then try again. 
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Figure 2 

Chapter 2 Software Basic Operation 
2.1 The Main Interface Operation 
After starting the software, the user will see an interface like that shown in Figure 2. 

Menu Bar:  The main functions of the software are implemented through the Menu Bar. 

Commands executed through the Menu Bar include some of the most basic functions, including File, 

Edit, Draw, Config, Handle, View, Help, Model, and Tool. 

System Bar:  Placed on the System Bar are some of the most commonly used command buttons 

which are chosen from the menu. 

Graphics Bar:  On the Graphics property bar are the basic attributes of graphics operations, including 

graphic location, size, scale, and processing number. 

Edit Bar:  The Edit Bar by default is on the left of the work area. On the Edit Bar are placed frequently 

used tools to make the operation more flexible and convenient. 

Align Bar:  Tools that allow Alignment of the selected objects. 

Layer Bar:  Changes the layer (color) of the selected objects. 

Control Panel: Use the Control Panel to complete laser processing of multiple tasks, layer parameter 

settings, axis control, processing, etc. 
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Edit Bar Tools 

 Selection Tool 

 Edit Node - When selected it pops up the Edit Node tools explained below 

 Draw Line – Hold Ctrl while drawing for a straight line. Horizontal or Vertical only. 

 Draw Poly Line 

 Draw Curve 

 Draw Box – Hold Ctrl while drawing for equal sides 

 Draw Ellipse – Hold Ctrl while drawing for Circle 

 Draw Text 

 Point  

 Capture from Scanner, Webcam etc. 

 LGP Tool for creating light guides 

 Delete selected 

 Horizontal Mirror 

 Vertical Mirror 

 Center Data 

 Matrix Copy 

 The Edit Node Selections 

Plus (+) node – touch and click with the Node Select cursor. A red square will appear. Double 

click to confirm the Node. 

Negative (-) node – touch and click with the Node Select cursor. A green square will appear. 

Double click to Delete the Node. 

Combine nodes – select two nodes on different items. They will turn green. Tap on “combine 

nodes” to join the selections. 

Break a Curve - separate node. Select node, it will turn green. Click on “break a curve” and the 

object will be separated into two overlapping nodes. 

 

Select two nodes then click to change a Curve to a straight Line 

If one node is selected, it will turn into a Bezier node that can be curved on both sides. If two 

nodes are selected, the line between them will be turned to a Bezier curve as well as the line 

preceding the first created node. 
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2.2 Language Settings 
During the installation process, the user can easily switch the language in which the application 

displays commands. The following steps outline the process of changing language in RDWorks. 

2.2.1 Language Settings And Manufacturers Information 
In addition to selecting the Language during installation the language can be easily switched within 

the software.  

Click on menu Bar [Help] -> [Language] and expand the menu, then select the desired language. 

The third one down is English. In Figure 3, we are using the Other Language file from 

RDWorksLab.com.  

It is the 4th selection, available from: http://rdworkslab.com/viewtopic.php?f=45&t=517  

 

 

 

 

 

 

 

When all Lines are in Chinese, Count down to the 3rd line down and click on it. 

 

 

 

 

 

 

 

 

To obtain the manufacturer's information, so that the manufacturer MIGHT provide you with better 

service, Click on menu Bar [Help] -> [About RDCAM] 

The bottom of the dialog box shows the current software version number. Different versions of 

software may have some differences in the functions and interfaces, you MIGHT be able to contact 

and communicate with your manufacturer and inform them of the software version number. This file 

is stored in the "Info_eng.txt” file located in the RDWorksV8/Vendor Folder or the Installed 

Folder/Vendor if you did not install it in the default folder. 

Figure 3 

Figure 4 

Cop
yr

igh
t 2

01
6 

RDW
or

ks
lab

.co
m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d

http://rdworkslab.com/viewtopic.php?f=45&t=517


This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 18 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

Figure 5 

2.3 Page Setting 
To control page setting, click on menu [Config(S)] -> [Page setting]. When this is done, the following 

dialog box appears (as shown in Figure 5):  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

[Page width]:  Software page width should be the same as the machine X width.  

[Page height]:  Software page height should be the same as the machine Y height. 

Once connected to the controller, the software will automatically format the page size for the current 

operation. However, if the controller is not connected or if a custom page size is needed (such as for 

adjusting page size to material), the user can use the page setting to reconfigure the page size as 

desired. 

[Grid] Enables and sets the grid spacing. Setting to 25.4 or 50.8 mm will give 1 or 2 inch spacing. 

[Keyboard] The user can use the arrow keys to move selected graphics. How far it moves is set in 

Keyboard Settings. 

[Color config] Sets the color of the work area as well as background and grid colors. Setting the Page 

Background to a Light Gray helps to see the lighter colored layers. 
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2.4 File Open And Save 
The software uses the "rld” file format to save graphic information, layer parameters, and the 

processing of graphic elements. 

2.4.1 Open File 

To open a file, click on menu [File] -> [Open], or click on the folder  icon to open the dialog box 

below: Select the desired file and click on [Open]. 

 

 

 

 

 

 

 

 

 

 

 

2.4.2 Save File 

(1)  Click on menu [File] -> [Save], or click the Disk icon.  This dialog box appears:  

 

 

 

 

 

 

 

 

 

 

(2) Enter the file name in the edit box, then click on [Save]. 

Figure 6 

Figure 7 
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2.5 File Import And Export 
Files not in rld format must be imported, and the Export function must be used to export graphic files 

for processing by other programs. The file types that can be imported include dxf, ai, plt, dst, and dsb 

as well as many other formats. Exported files are formatted as plt files or a proprietary ai format that is 

not readable by most programs other than RDWorks although we hear that Adobe Illustrator CS2 will 

work with these files. As far as I know, there is NO FREEWARE program that will open this older 

version of ai file. 

2.5.1 File Import 
To import a file, follow the procedure below. 

Click on menu [File] -> [Import], or click the Import  icon, to invoke the following dialog box 

 

 

 

 

 

 

 

 

 

 

 

 

 

For most vector files, the RDWorks software will automatically import the file into the corresponding 

layer of RDWorks according to the color layer description as set in your Layer Parameters. See 

Section 4.10.2.  

If the Preview Check box is selected, the file will be shown in the preview screen when selected. 

Click [Open] to open a selected file. 

Files by default import to the center of the work area, the import position can be set by clicking on 

menu [Config(S)] -> [File Parameter Setting] -> [Docking Import Data] and selecting the desired 

position from the drop down menu. See Section 2.5.03. Sometimes it is easier to use Ctrl-X to cut, 

then use Ctrl-V to place the file centered on where your cursor is currently positioned. 

 

Figure 8 
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2.5.2 File Export 

Click on menu [File] -> [Export] or click the Export  icon. The Export dialog box appears. 

Input the desired filename, select desired export file type and click the [Save] button. This saves in 

ai and plt formats only. The .ai does not play well with most other (freeware) software. I have been 

told that Adobe Illustrator CS2 will work with these files. As far as I know, there is NO FREEWARE 

program that will open this older version of ai file. 

2.5.3 File Parameters Setting 
Click on menu [Config(S)] -> [File Parameter Setting] 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PLT Precision: Select the appropriate import accuracy of the original plt file. Set PLT (plotter) 

precision to match the accuracy of the original plt file. You can enter your desired number or use 

one of the two defaults of 1016 or 1000. 

DFX Unit: Choose the units used to import a DXF File. Choices are MM, CM, Inch or Custom. 

Import DXF text info:  Un-check this option if you need the functionality of dxf graphic information, 

but do not need the text information within the file. 

Import dxf point: if this is checked, then point data from the dxf will be imported. 

Import image in AI files: if checked will allow importing an image that is in an ai file. 

Figure 9 
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Import DST support layer: DST and LSP - Uses the AutoCAD 2005 Field function to insert 

drawing name, date, and time of last save.  

Auto-close curves: This function automatically closes curves and compares them to tolerances 

set by the user.  

Combine lines: This function merges lines to user-set tolerances and auto-connects curves. 

Auto Rotate: When checked it will rotate the imported data by 90 degrees. 

Docking Import Data: gives 5 choices as to where imported data is placed. 

Export Settings:  

Mark Point as Zero, Allows you to set where the origin of the drawing is located. 

Processing while external calling, allows recursive calling in the software to speed saving in 

computers with more powerful processors. 

Enable Counting, allows counting of points processed during export. Can be Reset. 

Export precision: Sets the Export precision of the plt file or output file. 80% is the default but you 

may select higher or lower depending on your requirements. 

Project (projector) Setting:  

Enable fixed double head: Check this if you have a double headed machine and then enter 

the X and Y offset of the second head. 

Auto Fresh Projector: If checked, will automatically refresh the projector if so equipped. 

Unit Type: Select between inch and millimeter setting. The screen will switch to display in inches or 

millimeters. 

Velocity unit: The software supports two types of speed units: millimeters per second (mm/s) and 

meters per minute (m/min). The speed of the parameters in the Layer Parameters Interface is 

determined by the speed unit selected.   

Note: The displayed unit notation does NOT change in the Work Tab, on the Speed line but the 

actual number does change. 

 

 

 

 
Cop

yr
igh

t 2
01

6 
RDW

or
ks

lab
.co

m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d



This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 23 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

 

2.5.4 Image Library 
Click on menu [File] -> [Image Library] 

Frequently used graphics can be stored in the gallery for ease of use. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

New lib: Creates a new Library which you can Import graphics into. 

Del lib: Will delete the currently highlighted library. 

Add Image: Select library name, then the desired image, click on Add Image, enter a name for the 

image, click “OK”, then click on “Export all“. 

Del Image: Deletes the currently selected image from the library.   

Import/Export 

Open lib: Will open a library for use. 

Save lib: Will save a Library for later use. 

Import/Export: Will Import a graphic into a Library. Export does not seem to work. 

There are currently two versions of V8.01.19! A special one for L.O. Ruida controllers may allow 

Export. 

Import as a whole: If checked will import the complete file as one piece. If unchecked, the file will 

be imported in all of its component parts. 

Figure 10 
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Export Options: 

Original size: if Checked will export into RDWorks at the original size. 

If you change the numbers in the selection boxes, the box on the left is for the X dimension, the box 

on the right is for the Y dimension. 

Lock Scale: if checked, then only the X dimension can be selected, but the Y dimension will be 

scaled to be in the proper ratio to the original X & Y dimensional relationship. 

Export all: will export the graphic to the lower left of the work area. 

2.6 Creating Basic Graphics 
Lines (Ctrl+1):  To draw lines, do the following steps:  

Click on menu [Draw] -> [Line], or click the Edit Bar icon,  to select the line tool. Click and release 

in the processing area to create the starting node of the line.  Move the pointer to another location and 

click and release again to create the ending node of the line.  

Press the "Ctrl” key while moving the mouse to draw horizontal or vertical lines. 

Polygon/Polylines (Ctrl+2):  To draw poly-lines, do the following steps:  

Click on menu [Draw] -> [Polygon], or click the Edit Bar icon  to select the polyline tool.  Click and 

release in the processing area to create the starting node of the polyline.  Move the pointer to another 

location and click and release again to create an additional node.  Repeat until the desired polyline is 

complete.  Clicking on the starting point creates a closed polygon and resets the tool to start another 

polyline. Right clicking or pressing "Esc" creates an open polygon and exits the tool. 

Curves (Ctrl+3):  To draw curves, do the following steps:  

Click on menu [Draw] -> [Curve], or click the Edit Bar icon  to select the curve tool. The curve tool 

works much like the polyline tool.  Curve nodes have handles that can be manipulated to change the 

curvature of the segment connecting nodes.  Dragging while clicking simultaneously creates a node 

and curves the segment.  Right clicking or pressing "Esc" exits the tool. 

Rectangles (Ctrl+4): To draw rectangles, do the following steps:  

Click on menu [Draw] -> [Rectangle], or click the Edit Bar icon  to select the rectangle tool. Left 

click and hold in the processing area to create the starting node of the rectangle.  Drag while holding 

the left mouse button down to expand the rectangle.  Release the left button to end the rectangle and 

exit the tool. Press and hold the "Ctrl” key while dragging the mouse to draw a square.  

Ellipses (Ctrl+5): To draw ellipses, do the following steps:  

Click on menu [Draw] -> [Ellipse], or click the Edit Bar icon  to select the ellipse tool.  Left click and 

hold in the processing area to create the starting node of the ellipse. Drag while holding the left mouse 
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button down to expand the ellipse.  Release the left button to end the ellipse and exit the tool. Press 

and hold the "Ctrl” key while dragging the mouse to draw a circle. 

Text (Ctrl+6): To add text, do the following steps: Click on menu [Draw] -> [Text], or click the Edit Bar 

icon  and then click on the screen where you want to insert the text. Enter text, select font, set text 

height, width, and spacing in the pop-up text dialog box (as shown in Figure 13). Click [OK] to close 

the pop-up and apply the text settings. Text remains editable until you select the Un-group Icon  - 

near Top Left on the Toolbar.  

 

 

 

 

 

 

 

 

In the text dialog box illustrated in Figure 11, select the font type from the drop-down menu, and then 

set the width, height & line spacing. After applying these specifications, click [OK]. Note: The text in 

the text selection box will not appear to be the correct font, but upon exiting, it will be the correct 

font on the display. 

If one enables variable text by selecting the Check Box, two variable functions will be revealed: Date 

and Serial NO (Date & Serial Number). Each function has its own properties and formats that they 

must follow.  

 

 

 

 

 

 

 

 

 

Figure 11 

Figure 12 
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Select Date:  The date variable text supports 12 & 24 Hour formats and 14 different settings to 

choose from for Date Display. The time can also be updated automatically from your PC settings. Just 

be sure that the format is the same for both cases.  

Select Serial NO: (Serial Number) as used in packaging, engraving the expiration period or date can 

be used on the product. Example is if ABC0001DEF processes repeatedly, ABC0002DEF, 

ABC0003DEF until ABC9999DEF, this is a group of serial numbers. 

 

 

 

 

 

 

 

 

 

 

 

[Prefix]: serial number prefix, example ABC is the leading (prefix) string. 

[Suffix]: the serial number of the suffix, example DEF is the (suffix) string after. 

[Start SN]: the specified number to start manufacturing, example is to start at 0001 serial number. 

Using 1 will only allow one digit before being reset to 1 again. Using 0001 will allow up to 9999 before 

being reset, depending on the [Enable Reset] setting. 

[Current SN]: the current processing serial Number. It can be used to specify the current processing 

serial number. When processing a group of serial numbers, in some cases a group of serial numbers 

require repeated processing, namely to a serial number, then it needs to go back to the [Start SN] 

(start serial number) to restart manufacturing. 

[SN Inc]: the interval number can be a prescribed sequence number. The example will process from 

0001 to 9999 serial number, the increment is 1. If the number needs to output only even or odd 

numbered serial numbers, then set the increment to 2. 

[Enable reset]: when the serial number reaches the reset number, the [current SN] will be 

automatically reset to the [start SN]. 

Example:  if you require repeated processing serial Numbers, from 0001 to 9999, then 9999 can be 

designated as the reset number. When the serial number reaches 9999, the serial number text will 

automatically change back to 0001, providing [Enable prefix ZERO] is enabled. 

Figure 13 
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[Enable prefix ZERO]: if not enabled, the system will automatically remove the leading zero(s) in the 

serial number.  

Example: Serial Numbers, if enabled, then a serial numbers leading zero(s) will be ABC0001DEF but, 

if not enabled, it will become ABC1DEF. But it is worth noting that, if we want to output the serial 

number ABC1DEF, ABC2DEF until ABC9999DEF, we can't do this through the [start SN]  by setting it 

to 1 to achieve this, as it must be done by canceling the [Enable prefix ZERO] to achieve. This is 

because setting the specified number from the [Start SN] specifies the number of significant digits, 

used to begin to serial number. So, if the number is set to 1, the change in the serial number order is:  

1,2,3,4,5,6,7,8,9,0,1,2,3,4,5... The serial number won't change to 10, because the serial number had 

only one place holder, whereas 0001 has four place holders. 

[Enable SN array]: used for one-time processing more serial numbers, for instance:  

0001 0002 0003 after this batch is processed, then,  0115 0114 0113 
0006 0005 0004 skips directly to the next group of  0007 0008 0009 
0016 0017 0018 or do these numbers two times  0016 0017 0018 

Point (Ctrl+7):  To draw points, do the following steps:   

Click on menu [Draw] -> [Point], or click the Edit Bar icon  the point will not be processed by the 

laser but it will affect the start point (green dot). 

Capture / Twain Import (Ctrl+8):  To Capture or Import from Twain, do the following steps:  

Click on menu [Draw] -> [Capture], or click the Edit Bar icon  if the computer has been connected 

to a Twain Compatible scanning device, a dialog box will appear. This dialog box enables the user to 

import pictures from a specified device as shown in Figure 14.  

 

 

 

 

 

 

After selecting the scanning device, the pictures from the specified device are imported into the 

drawing area. 

 

 

 

 

Figure 14 
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2.7 Object Selection 
The first step in drawing and editing graphics is the selection of the initial object. This can be done by 

clicking on it while in the Selection mode. An x-shaped mark will appear in the center of the selected 

object, which will also be surrounded by eight control points (as shown in Figure 15). Click and drag 

any of these points to re-size the object. Drag diagonally to change height and width at the same time. 

Click on menu [Draw] -> [Select], or click the Edit bar  icon to switch, to 

"Select.” status. This status enables the user to select an object. Objects may 

be selected in five different ways:  

1) Click on menu [Edit] -> [Select All] (Shortcut is Ctrl+A), and select all objects; 

2) Click on the screen to select a single object; 

3) Select an object by left clicking and dragging the cursor diagonally over the 

object, creating a graphic select box that encloses the object. As long as the 

box fully encloses the object, it will be selected; 

4) Use the "increased select object/minus select object” process, which includes the following steps:  

Increase select: Press "Shift” key, click or box select to increase select object. Minus select: Press 

"Shift” key, click or box to deselect the selected object. 

5) Select the object according to layer. To select an object according to layer, right-click the selected 

layer to select all objects in that layer (as shown in Figure 16). Does not work with grouped objects. 

 

 

 

 

 

 

 

 

2.8 Object Color 
The color of an object is the color of the objects outline. You can click the color button on the Layer 

Bar to change the color of the object that has been selected. The color of the pressed button will make 

the current layer that color. Also, anything created from that point on will be that color. If you import a 

file with colors, they will be added to the work layer but not to the color bar. Color Bar colors are RGB 

colors. 

 

 

Figure 15 

Figure 16 

Figure 17 
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2.9 Object Transformation 
Transformation refers to a change in the location, orientation or size of an object. Changes to the 

basic shape or characteristics of an object usually are not considered "transformations.” 

 

 

 

The object transformation menu (Figure 20) – provides a convenient interface for users wishing to 

change the location, orientation or size of a selected object. The user can mirror and rotate an object 

within the draw toolbar. The user also can use the Object Properties toolbar to transform objects.  

 

 

You can also use the [Control Panel] -> [Transform] Tab tools to transform and copy the graphics. 

 

 

 

 

 

 

 

 

 

 

 

 

2.9.1 Object Flipping 
After selecting an object, the object may be flipped about its horizontal or vertical axis by clicking on 

the horizontal  or vertical flip  icon, respectively on the drawing tool bar. 

Images may also be flipped by using the transformation tool (shown in Figure 20) to mirror and 

copy either the horizontal or vertical aspect of the object. 

 

Figure 18 

Figure 19 

Figure 20 
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2.9.2 Object Rotate 
Referring to Figure 21, an object can be rotated by first double left clicking twice anywhere on the 

object, and then by clicking on the appropriate corner icon and rotating clockwise or counter-

clockwise. 

To drag rotate, move the cursor to a corner  and then press & hold the left mouse button 

key. 

Drag the cursor to adjust the angle of rotation. Note that the rotating wire-frame outline will 

accompany the dragging process. 

The user can enter the precise angle of rotation in the Object Properties toolbar (Figure 19), 

positive numbers are counter clockwise and negative numbers rotate clockwise. You may also use 

the spin rotation transformation tool (Figure 20) to set and lock the center of rotation. 

 

 

 

 

This only works properly for Vector Objects. If you try to rotate a bitmap picture it will rotate in 90 

degree increments. 

 

 

 

 

 

 

2.9.3 Object Size 
 

 

 

The screen captures above and below show how one can adjust the size and positioning of a 

selected object.  

 

 

Figure 21 

Figure 22 

Figure 23 

Figure 24 
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Size can also be changed by using the size transformation toolbar. This toolbar can be used to 

modify the size, to lock or unlock the aspect ratio, and to set the position relative to the object being 

modified. By clicking on the padlock, so the padlock is locked, one locks the size ratio such that if 

the X size is changed, the Y size will change proportionally with X. The same can be said for the % 

change. If Y is changed by 50% then X will be changed by 50%. The Icon to the right of the padlock 

positions the object to one of 9 positions. The default position is centered. Should one position 

elsewhere, the left hand X and Y positions will be reflected the selected edge position. 

2.9.4 Object Tilt (Skew) 
An object can be tilted by the tilting transformation tools (Figure 25). It can set the tilt anchor and 

the tilt angle. The tilt will cause distortion of the object and the practical application is for only a 

small object or portion of an object. Currently it only supports the tilt of vector graphics. 

 

 

 

 

 

 

 

 

 

 

 

2.9.5 Object Array Replication 
To replicate objects, select the object to be copied. The user then opens the "Array copy” dialog 

box (Figure 26) by clicking the icon. 

Note:  Bestrew = Distribute 

Click on Bestrew (Distribute) and it will array as many copies as the X and Y size is set for. You 

must set the X offset space and the Y offset space.  

Figure 25 

Figure 26 

Cop
yr

igh
t 2

01
6 

RDW
or

ks
lab

.co
m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d



This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 32 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

The user can replicate an array in different directions. The direction of copying is based on the 

original graphics. If the user chooses "lower right” as an array direction, the original graphic will 

appear in the upper left corner. Similarly, if the user chooses an "upper left” array direction, the 

original graphic will appear in the lower right. 

After setting the array number and array spacing, the user can click the [OK] button to see the 

actual graphics array. 

There are two forms of array spacing; center spacing and edge spacing. To choose center spacing, 

the user must use the [X Distance (mm)] function to define the horizontal distance from the center 

point, and the [Y Distance (mm)] function to define the vertical distance. 

Alternatively, the user can use edge spacing, in which the [X Distance (mm)] and [Y Distance (mm)] 

functions represent the horizontal and vertical distances from the edge of the graphic. In this 

connection, it is useful to remember the following two relationships:  

Center distance X = Edge distance X + ½ width of object 

Center distance Y = Edge distance Y + ½ height of object 

These relationships allow quick conversion from one orientation to the other. 

By clicking the [Bestrew...] (Distribute...) button, the user can make the software calculate the array 

number according to the size, width, height, X distance, and Y distance of the work piece. 

2.9.6 Placing The Object Relative to the Origin 
RDWorks provides the following tools to control the placement of a selected object:  

Clicking the  icon results in the placement of the object in the center of the page, such that the 

center of the page and the center of the object overlap. 

The use of the  icons causes the selected object to be placed in one of the upper 

or lower, right or left hand corners. 

 

 

2.10 Object Alignment 
The precise alignment of objects can be determined by making use of the tools provided by the 

Alignment Bar. The specific functions invoked by the icons on the Alignment Bar include the following: 

  

• From left to right, these icons cause left alignment, right alignment, top alignment, bottom 

alignment, horizontal center alignment and vertical center alignment.  
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• From left to right, these icons cause an object to be placed at a horizontally equidistant point or 

at a vertically equidistant point. This requires 3 items to be selected. Item will be centered 

between the furthest items apart. 

 

• From left to right, these icons cause objects to have the same width, the same height, or the 

same size as the last selected object. This requires two items to be selected. The last item 

selected is the Benchmark Item and the action will be performed on the item(s) prior to the 

benchmark item. 

 

• The purpose of these controls are UNKNOWN at this time. 

RUIDA has said, “These Icons are [of] no use now, maybe it will add some functions in the 

future.” 

Benchmark Object:  All tools work from the last Object Selected. 

If you press the "Shift” key and select objects one by one, then the benchmark object is the last object 

selected. If you select the object by the select box, then the benchmark object is the object that was 

the last selected object. 

2.11 Object View 
Roll the Mouse Wheel to Zoom In or Out at the Cursor's Location. 

Move: Click on menu [Edit] -> [Move], or click.  Then hold down the left mouse button in the 

drawing area, and drag and pan. 

Zoom Out: Click on menu [Edit] -> [Zoom Out], or click . With each click, the drawing area will 

zoom out once. Move the mouse to the drawing area and click. With each click, the mouse is 

positioned as the center of the drawing area and will zoom out once. 

Zoom In: Click on menu [Edit] -> [Zoom In], or click . With each click, the drawing area will zoom 

in once. Move the mouse to the drawing area and click. With each click, the mouse is positioned as 

the center of the drawing area and will zoom in once. 

View Select: Click on menu [Edit] -> [View Selection], or click . Move the mouse to the drawing 

area, hold down the left mouse button and drag, a dashed border box will show in the drawing area, 

release the mouse button, then the region in the dashed border box will display enlarged and centered 

in the drawing area. 

Cop
yr

igh
t 2

01
6 

RDW
or

ks
lab

.co
m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d



This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 34 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

View Page Frame: Click on menu [Edit] -> [View Page Frame], or click . The full page frame will 

display.  

View Data Frame: Click on menu [Edit] -> [View Data Frame], and click . The selected objects will 

fill the display area. Note, an object must be selected to enable this icon. 

2.12 Group And Un-Group 
Groups will cut together. They will not select with Right Click on Color. When used in conjunction with 

the [Edit] -> [Set cutting properties] feature as described in Section 2.13, there are powerful benefits to 

be had. See: https://www.youtube.com/watch?v=_3oUQ9gKjCk   

Another extremely useful feature of this function is for manipulation, and justifying, text. See: 

https://www.youtube.com/watch?v=_NluzdiikNg   

Often times various individual graphics must be grouped together, or un-grouped, for one operation or 

another. Grouping and un-grouping is accomplished by selecting a group of graphics, or a previously 

grouped aggregate of objects, and then Click on menu [Edit] -> [Group] or Click on menu [Edit] -> 

[Un-group], or by clicking the group or un-group icons  on the toolbar.  

2.12.1 Additional Tools 
 

 These tools are additions in V8.01.19.  
Projector: 

Allows adjusting a projector. As we do not have one, we cannot comment on this. 

Docking Point: 

Allows you to set a return to point after a job. This point is an absolute position from your machines 

home location. I set mine to X200 Y0.  But if all you do is give it a docking point, it still returns to the 

start location of your part by default. So we need to go into user settings and make a change. 

Make sure your computer is plugged into your laser, and the laser is on. Then in RDWorks, go to your 

User tab. And click “Read” at the bottom. This will load your machines user settings. Now you need to 

scroll down to the “Other” section and find the option for return position. It should read Absolute Origin. 

Change it to "Not Return". Now click write, to upload the changes to your machine.  

Now your machine will return to this given location after each job. It will retain this position between 

part files and sessions as well. And of course you can change it, or turn it off as well. 

See http://rdworkslab.com/viewtopic.php?f=3&t=505  Cop
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Measure Tool:  

To use the measure tool, click on it, then in the display area, left click and release to set the datum 

point. As the pointer is moved, the distance from the datum to the pointer is displayed on the 

information bar at the bottom of the screen. Left clicking again terminates the measurement tool and 

statically displays the distance between the datum and the second selected point. The measurement 

displays on the bottom bar towards the right hand side. 

2.13 Important Tools 
The following tools can be used to optimize the order and direction of object processing. 

2.13.1 Manual Sorting And Setting Of The Cutting Point And Cutting Direction 
RDWorks provides users a convenient tool for the manual sorting of graphic objects. To make use 

of this tool, the user should Click on menu [Edit] -> [Set cutting property], which will invoke the 

cutting property dialog box (Figure 27). This dialog box can be used for manual sorting and the 

setting of cutting points and cutting order. 

The Arrow works as a “Lock Button”.  If the button is not pressed, when you place your cursor 

on the page being ordered, you can drag the page around. If you press the “Arrow Button” you will 

not be able to move the picture around. If you scroll the picture, it will zoom In and Out regardless 

of the “Lock Button”. Now, your picture may not be centered or wholly view-able in the window. 

Press the  Button and regardless of the lock arrow, the picture will be re-sized and centered in 

the window. 

 

 

 

 

 

 

 

 

 

 

 

Show path:  By checking the "Show Path” button at the bottom right of the cutting properties dialog 

box, the user can see the current graphics cutting order and the cutting direction. 

Figure 27 
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Manual sort:  By selecting the "Lock” icon,  (see Figure 27) the user can switch the current status 

of the operation between view and edit. The user can then highlight or click the objects in the object 

display area. After selecting an object, the user should select the  icon to have the graphics 

redirected to another list where they can be re-ordered. Continue selecting and pressing the  icon 

to move another object to the right hand column to re-order the laser sequences.  A sequence of 

operations is then performed on the objects before the selection is completed. To change the direction 

of graphic processing, the user should first select the targeted graphic in the graphics display area or 

in the list, and then click  the Reverse button. If the work area contains vector and BMP 

images, no matter where you place the BMPs in the processing order, they will AWAYS be processed 

before vector objects. The order of objects may be raised or lowered by using the  and  arrows 

when an object in the right hand column is highlighted. 

Use the preview window to check processing order before saving to U file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To change the cutting order, first select the graphic and then inspect the nodes in the display area. If 

in “Edit mode” using the Lock Icon , a new node can be selected as the starting point by double-

clicking the mouse on it. This is within each separate box, not between boxes. After all changes have 

been completed, click on  to save the changes.  

Figure 28 Cop
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In addition to cutting property features, RDWorks also offers tools to change the cutting order, cutting 

direction and cutting start point. To do so, select the  icon in the toolbar, or click on menu [Edit] -> 

[Show Path]. 

 

 

 

 

 

 

 

 

Choose the object that should have the cutting order changed, and the  process 

number of the current primitive will display in the object properties bar. Another method to change the 

cutting order is to enter the cutting number directly in the Processing number box, and then press the 

keyboard "Enter” key, or click the plot area. 

Changing Graphic processing direction: To change the processing direction, click [Edit] -> [Set cut 

direction]. Then you can double-click on any position of the selected graphic. A small red arrow on one 

of the objects nodes will change direction to indicate the direction the object will be processed. 

Changing the cutting point:  To edit the cutting point, click [Edit] -> [Set cut point] to enter the 

"Change cutting point” mode. To select the curve to be edited, double-click on the node identified as a 

new cutting point. 

 

 

 

 

 

Figure 29 

Figure 30 
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2.13.2 Setting And Editing The Cut In/Cut Out Lines 
This is very similar to lead in and lead out in CNC machining. For most cuts this feature is not 

needed. By default, a drawn or imported curve does not have any cut in/cut out lines. To add such 

lines, select the objects and then invoke the "Cut in and out setting” dialog box (see Figure 31) by 

Clicking on menu [Edit] -> [Edit cut in property], or by clicking the  icon. 

 

 

 

 

 

 

 

 

To make cut in/cut out lines, the user must first enable the cut-in/cut out function. Straight line cut-

ins are created in three ways:  

• By cutting in at an angle. In this procedure the cut in line and starting segment form a specified 

angle (in which counter clockwise angles are positive) and ~0 to ~180 degrees are usually 

inside the graphic. 

• By cutting in at the center, and by making the starting point of the cut-in line at the center; and 

• By cutting in at the center, drawing the cut-in line from the center to the starting point, and by 

assigning it a specific length. 

With the “Cut In - Enable” check box selected, the laser will curve in to the selected edge tangent 

to the direction of the vector at the point it actually reaches the edge. Checking the “Cut Out - 

Enable” box results in an exit lead being added to the path at the end of the path, off the cut edge. 

The “Length:” and “Angle” require setting. 

The processing of setting cut out lines is the same as setting cut in lines. 

Clicking on menu [View] and selecting “Cut In/Out Bar” will give you the control in figure 35. 

 

 

With a selected object, you are able select “In cut” or “Out cut”, “Auto”, select dimensions and 

direction as in the description above, using the “Cut In/Out”, Check the drawing and Draw the Cut 

In or Out. See “Kerf” for an additional use for this bar. 

We have no real use for this as Cut In/Out as it is not required with our low powered lasers. 

High power metal cutting lasers might be able to make use of it. 

Figure 31 

Figure 32 Cop
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2.13.3 Path Optimization 
Path optimization relates primarily to the re-ordering of vector graphics.  

Note. At the bottom right of screen just below the “SavetoUFile” button is a path optimize check box 

(see Figure 33). If this is ticked it will override and mess up the choices you have made in the 

Cutting optimize handle window. UNTICK IT.  

To begin the path optimization process, click on menu [Handle] -> [Cut optimize], or click the  
icon, and the “Cutting optimize handle” dialog box appears (see Figure 34).  

 

 

 

 

 

 

 

 

To view the cutting path before and after processing, the user should Click on menu [Edit] -> [Show 

Path], or click the  icon. The graphics cutting path always starts from the laser head. Objects which 

are Grouped are cut together – Grouped inside objects are cut first IF selected first, then the outside 

objects are cut. Path optimize needs to be unchecked, or it will not cut as shown.  

Cutting optimize handle: 

Order of layer: if checked will cut using the order of the layers. 
Inside to outside: if checked will cut from inside to the outside. 
Block handle: Height will include those items that are within the entered distance as preferred cutting 
objects. Items further away will be cut later. 
Dir: Selects one of the four start areas and direction of cutting. 
Start point optimize: if checked will try to determine the optimum start point. 

The effect of all of these selections can be seen if “Show path” is selected. 

 

 

 

 

 

 Figure 35 

Figure 34 Figure 33 

Figure 36 
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2.13.4 Curve Smoothing 
For curves that do not require a high degree of precision, the curve smoothing function can be used 

to make the curves appear smoother and to speed up processing. To invoke curve smoothing, the 

user should Click on menu [Handle] -> [Curve Smooth], or the  icon. These keystrokes invoke 

the curve smoothing dialog box (see Figure 37). 

 

 

 

 

 

Select Low, Middle, High or Custom. 

If Custom is selected you will then see the Curves Smooth Dialog Box. (Figure 38) 

 

 

 

 

 

 

 

 

 

 

 

Smoothing is effected by dragging the smoothness slider (at bottom left) to the desired point, and by 

then clicking the [Apply] button. The curves before and after smoothing will be visible in the dialog 

box; black curves represent originals, red curves represent smoothed curves. 

You can zoom in or out of the smoothed curves by rotating the scroll wheel on the mouse. The largest 

view of the smoothed graphic can be obtained by clicking the [Full Frame] button in the dialog box. 

After the desired smoothing effect has been obtained, the [Apply] button should be pressed to save 

curve smoothing settings. 

Figure 37 

Figure 38 
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2.13.5 Closure Check 
To check closure, invoke the "Setting close error” dialog box (Figure 39) by clicking on Menu 

[Handle] -> [Curve auto close], or by clicking   on the System Bar. 

 

 

 

 

 

Setting the "Close error” defines the distance in millimeters from starting to ending point. When the 

distance is less than this "Close error” tolerance, the curve is closed automatically. The "Force to 

close” box forces the closing of all selected curves. 

2.13.6 Removing Overlap 
To remove overlaps, invoke the "Delete overlap lines” dialog box (below) by clicking on menu 

[Handle] -> [Delete overlap] or click the  icon. 

 

 

 

 

 

Under normal circumstances the user should not select the "Enable Overlap error” function. This 

appears to only work if the lines are the same length.  It works well with box joints like those 

produced by http://www.makercase.com/ if you are using line-to-line fits.  Then you can overlay the 

edges of your panels, use this to delete the overlap and you get the most compact layout and 

fastest processing possible. If removing overlapping lines does become necessary, it is important 

that the user not make the overlap error too large in order to avoid accidentally deleting lines that 

should be retained. 

 

 

 

 

 

Figure 39 

Figure 40 
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2.13.7 Combine Curve 
To combine or merge curves, invoke the "Setting combine error” dialog box (below) by clicking on 

menu [Handle] -> [Combine Curve], or by clicking the  icon. 

 

 

 

 

 

 

The software automatically merges selected curves when the merge tolerance is less than the 

value set in the "Combine error” box in millimeters. 

2.13.8 Bitmap Handle 
The Bitmap Handle function sets image characteristics of bitmaps such as size, resolution, 

brightness, contrast, and color. To invoke the "Bitmap handle” dialog box (below). Load a bitmap to 

the work space, select it and then click the  icon or Click on menu [Handle] -> [Bitmap handle]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

The top right of the dialog box displays the information for the selected image (as shown in Figure 42).  

Figure 42 

Figure 41 
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Other options associated with this function include the following:  

[Apply to view]. Until this button is clicked, the most recent changes are only previewed without 

affecting the original bitmap. Before the [Apply to view] button has been clicked, the [Cancel] button 

at bottom right of the dialog box can be pressed to return to the original image. Thus, this option is 

good for trial-and-error adjustments to an image, but it requires more time and memory than other 

options. 

[Apply to source]. With this setting, changes are made directly to the source image, and pressing 

[Cancel] will not restore an altered image to its original state. Therefore this option is mainly used in 

a multi-step operation, such as transforming general pictures into gray scale. Such sequential 

processing saves computing time for follow-up operations. 

[Save as]. This button retains the results of the previous operation, allowing a processed image to 

be exported/saved to the hard drive. Therefore [Save as] is often used in conjunction with [Apply to 

view]. In general, use the [Save as] function to facilitate subsequent processing. 

[Gray scale]. All imported graphics are forced to gray scale mode. You may adjust contrast and 

brightness to have some auxiliary effect to the graphic. 

The following images show an image before and after specific processing functions:  
 Before Processing After Processing 

 

 

Adjust Contrast 

  

 

 

Invert 

  

 

 

Sharpening 
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There are three methods for dither processing: Net graphic, Dot graphic, and Black and white. 

Net graphic:  This function adjusts net size and is better suited to low resolution material, or when the 

laser is cutting relatively slowly. To get the appropriate net size, the user can adjust the resolution and 

net frequency of the image. The higher resolution, the more delicate. The higher net frequency, the 

smaller the net size, and vice versa. Image resolution is generally set at 500 – 1000 pixels, while net 

frequency is set at 30-40 lines. 

 

 

 

 

 

 

Dot graphic:  

Dot graphic performs well with gray scale images. It is better suited to high resolution images, and to 

operation in which laser response is fast. 

 

 

 

 

 

 

 

Black & White:  

In most cases, changing color into black and white image produces poor quality images. It is however, 

very easy to use for clear outline images. 

 

 

 

 

 

 

Net Graphic 

Dot Graphic 

Black & White 
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Get Outline: 

Note that the "Get outline” button is found at the bottom right of the "Bitmap handle” dialog box (shown 

in Figure 43). This is an “Auto Trace” function that only works with some sharp edged graphics.  

 

 

 

 

 

 

 

 

 

 

 

 

 

2.13.9 Processing Preview 
To preview processing, invoke the "Preview” dialog box (illustrated in Figure 44) by clicking menu 

[Edit] -> [Preview], or clicking the System Bar Preview icon . 

 

 

 

 

 

 

 

 

 

 

 

Figure 43 

Figure 44 

Cop
yr

igh
t 2

01
6 

RDW
or

ks
lab

.co
m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d



This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 46 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

RDWorks supports previewing of the documents undergoing processing. The user can get important 

basic information from the preview. For example, the preview shows the path of the actual output of 

the processing, the general processing time, and the processing distance. The cutting process can 

also be simulated.  

Note:  Exiting the Preview Mode before pressing the "Stop” button and stopping the simulation can 

cause the software to crash if it is a large file. 

In addition to the current edited file preview, you can also preview the files that have been saved as 

rd. To preview an rd file, first double-click in the graphics display area. Choose the graphic to 

preview in the pop-up dialog box, and then open it. 

 

 

 

 

 

 

 

 

RDWorks also allows parameters to be set during preview. This works with RD type files. To do so, 

invoke the configuration menu (shown in Figure 45) by right-clicking anywhere in the graphics 

display area. Select "Config” in the pop-up dialog box. 

When the preview button is pressed the screen shows a gray scale image of the proposed program, 

where various shades of gray represent different power settings. When you invoke a simulated 

cutting cycle the path of the laser overwrites the gray image with a colored line whose color again 

varies with the programmed power. There is a configuration menu that allows you to change these 

colors (Figure 46). 

 

 

 

 

 

 

 

 

Figure 45 

Figure 46 
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2.13.10 Data Check 
To check graphics data, invoke the "Data check” dialog box (in Figure 48) by clicking the menu 

command [Handle] [Data check], or the system toolbar icon . 

 

 

 

 

 

 

 

 

 

When the user clicks the "Check” button at the lower right of the dialog box, data problems will be 

shown in the dialog box. The problems/results will be shown in the selected graphics. These 

graphics should then be repaired. The data inspection process should be repeated until all of the 

data conforms to the requirements of the processing. 

2.13.11 Generate Parallel Lines / Offset 
Select to create parallel lines around the graphic, click on the menu commands [Handle] / [Offset 

poly], or click the  icon on the system toolbar. The Red line in the figure is the original selected 

graphics, the outside Blue line is the outside offset graphics. 

 

 

 

 

 

 

 

 

 

 

 

Figure 47 

Figure 48 

Figure 49 
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2.13.12 LGP design - Light Guide Plate 

Click the menu commands [Edit] -> [LGP design], or click the drawing toolbar  icon, and you can 

start the LGP design tools, the tools are specific to block the sun reflections as an independent 

function. If the user does not need to block the sun or to make Edge Lit Signs or surfaces this 

section can be ignored. 

The three Tabs of LGP Design. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 50 
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We start with a blank slate and the design tools, we first need to design an outline of the light guide plate. In 

the tools, the default is 200 x 200 rectangular guide blank slate outline. The user can, using the tools of the 

"System page” manually create a desired shape for the light guide blank slate outline. 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Software also supports the exporting of the light guide plate design to the RDWorks main program 

for processing. 

 
 
 
 

 

 

 

Created using the default setting, the outline can use a rectangle or an oval. The user can also import 

a good graphic design, to use as the outline of the light. Click on the "Create LGP” button, and you 

can choose to have the outline of the document as the light. The outline file must be closed graphics, 

otherwise, the system will automatically delete it. 

If the outline of the imported graphic is within the size requirements, users can also change the size 

outline, and can set it up to keep a white edge. 

With the Outline graphics, they can start on the blank slate and increase the network. Network is 

divided six ways: horizontal, vertical line, elliptical, rectangle, reticle and the grid. 

Figure 51 

Figure 52 Figure 53 
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Baseline is related to the light source, the user can adjust the baseline position according to the light 

source. In the figure above red graticule marker is the baseline, users can move the mouse to 

baseline, press the mouse, and then drag the baseline to desired position. 

The entire guide baseline reflex is divided into four regions, level above baseline definition for uplink 

and downlink below is defined as;  

Vertical baseline definition for the left column on the left, the right to define right column. 

Set the respectively size and spacing for the network in up, down, left column, the right column initial 

values and the gradient of the change, and users can form the desired effect. 

For the grid method, one must change the column that will appear on the grid. 

For the convenience of application, for the system to provide the light setup, if the light source is a 

standard, you can choose the light source, then set the network parameters, and you do not need to 

adjust the baseline. At this time, the baseline shows or hides. 

 

  

Grid Method Elliptic Method 
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Reticle Method Rectangle Method 

 

 
 

Horizontal Line Vertical Line 

  

Left Light Source Right Light Source 

  

Top Light Source Bottom Light Source 
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Figure 54 

Horizontal, Vertical Line, Reticle, Elliptical.  

Rectangular setting is the network scanning mode of output. 

Scanning mode, the minimum energy, maximum energy generally 

is the same, and default the delay is 0. By adjusting the scanning 

system precision, to adjust the scanning density for higher 

accuracy the finer the scanning line is. Scanning with lower 

accuracy, the scan lines are sparser. 

The grid processing methods of cutting, and scanning is not 

precise and can be adjusted according to the actual effect, the 

maximum and minimum energy light type of delay, generally 

speaking, the least energy gives a slightly lower effect than the 

maximum energy. 

If you need to cut the reflex outline, you can make a contour cut. 

Cutting parameters and the common cutting Settings in here are 

identical. 

If you need to process the array as in processing more panels, the 

array parameters can be set. The array direction along the 

machine is always the origin in the opposite direction. 
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Figure 55 - An example of LGP design 
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An excerpt from a post in the RDWorksLab.com forum by Dropcat  

http://rdworkslab.com/viewtopic.php?f=3&t=227 

Took me a while to find the Import option under the System tab. I saved my name as a file, imported 

that, and it put the dots inside each letter. Neat.  

I also noticed under the System tab I can select Rectangle or Ellipse to set the shape. OK, I got this 

sussed out. The UI is terrible, but the concept is simple once you wrap your brain around it. One 

problem is it doesn't disable some entries when it should, and you get confused when fiddling with 

those and it does nothing.  

The theory is, you want a few big widely spaced dots near the light source, and lots of tiny closely 

spaced dots far away from the light source. 

To keep it simple leave it set to the default, so a 200 x 200 mm box. For 'Light source' leave only Top 

ticked, so this is an edge-lit sign you'd hang from the ceiling with the light at the top.  

Define the LGP type as ellipse, and set its size using the Width & Height boxes. Of course to get a 

circle set them the same, so 1mm. 

For now set the UpGrad & DownGrad to 0mm, and under Space set Up, Down, Left, & right to 5mm 

and the Grad values to 0mm 

Under 'Dislocation' (Offset) un-tick both row & column. 

Click 'Create LGP' and you get an evenly spaced grid of dots, all the same size. 

Dislocation alternates the grid spacing, tick either row & column, then 'Create LGP' to see the effect. 

Turn both off for the moment. 

Grad is short for gradation, the idea is to set the SMALLEST dot size & row spacing, and then set 

how it should increase.  

Read the above again! 

Below Height & Width you have UpGrad, DownGrad etc. This sets how the size of the dots change 

depending on how far from the light. Now this is kind of backwards, since we are starting from the 

smallest dot (away from the light at the top) you want to set UpGrad.  

This is the dot size increase for each row. The first UpGrad value increases the dot width, the second 

the height. Make them both the same, say 0.1mm to keep them as circles. So the first row of dots will 

be 1mm, the next 1.1mm, then 1.2mm and so on. 

Set both to 0.1mm and update. You'll have small dots at the bottom, big at the top. (Remember the 

light is at the top.) 

Setting the DownGrad numbers does nothing, they should be disabled like Left & Right are. 

(If the light was at the bottom then everything said above would be reversed, and the same for Left & 

Right.) 
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Row spacing follows the same idea; you have a default start spacing, and then the step size. (Again 

Down does nothing, only set the Up values). Leave Up as 5mm, and set the Grad to 1mm. From the 

bottom the first row spacing will be 5mm, then 6mm and so on. 

Notice you can set Left & Right, this sets the spacing of the columns. You should probably make those 

the same as the Up spacing. You can't set the Grad which is fine as the light source is at the Top. 

The dot Grad needs to be smaller than the Space Grad, otherwise you'd lose the gaps between the 

dots.  

For a square if you ticked both Top and Bottom light sources, the row would start in the middle and 

head towards the edges. Size & Row figures should be set identically. 

For a circle pattern you'd tick all four light sources, and set all the spacing & graduation figures to be 

the same for an even pattern. In that case the smallest dot would be in the middle, and everything 

would work outwards. 

I'm not sure what good numbers would be, maybe someone can measure one of those LED lights as 

per the video. You'd be using numbers in the 0.1mm size & 0.001 grad range I guess. 

Interestingly there are some minimum sizes, like the shape size can't be below 0.1mm and spacing 

below 0.5mm. 

 

The best way to learn how to use this really fun function is to play with it. 
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Chapter 3 System Settings 
Before graphics can be output, it is important to ensure that the system settings are correct. To do so, 

Click on menu [Config(S)] -> [System Setting] to invoke the dialogue box. 

 

 

 

 

 

 

 

3.1 General Settings  
Click on menu [Config(S)] -> [System Setting] to invoke this dialogue box.    

 

 

 

 

 

 

 

 

 

Axis Mirror: 

Generally, the Axis direction of the mirror is based on the actual location of the limit switches or the 

home location of the machine. RDWorks uses Cartesian coordinates, also known as X-Y coordinates, 

by default. 

If the home point of the machine is set to the top left, then the X-Axis does not need mirroring.  

Although you do not need to mirror the X-Axis you still need to mirror the Y-Axis.  

If the home point of the machine is top right, then both X-Axis and Y-Axis need to be mirrored. If your 

graphic or text is reversed or flipped, you have not set the mirroring correctly. Frequently, it is just the 

Y-Axis that needs to be mirrored. If the LCD displays reversed, see 

http://rdworkslab.com/viewtopic.php?f=39&t=483 or view Section 1.8. 

Figure 56 

Figure 57 
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Laser head: 

Position of Laser head means the location of the laser head relative to the graphic. 

 

 

 

 

 

 

 

 

 

 

 

 

This green determines how the program is written. If you have selected SCAN mode for any parts of 

your program, the top 3 dots will cause the scan to progress DOWN the image. Selecting the start 

point in any of the other 6 positions will create a program that scans from the BOTTOM upwards. 

Small Circle Speed Limit: 

Cutting, or engraving, small circles may be difficult for your machine. Moving the weight of the laser 

head around the diameter of a small circle can cause faults. If the speed of the laser head is limited to 

counteract any momentum issues the accuracy of small circles may be increased. 

 

 

 

 

 

 

Note: the settings in the example from top to bottom are 1.1 mm then 2.1 mm. not #1, #2 .Click the 

Small circle speed limit check-box, then click on [Add] to add a setting.  

 

 

Figure 58 
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To delete a setting, Select a line and then click on [Delete]. 

Scan backlash: 

Backlash is caused by the inclusion of a small amount of clearance, or play, needed to allow the cogs 

and drive belts to move without putting too much force on any component. Rubber belts have an 

inherent amount of give, they just like to stretch and when the laser head reverses its direction the 

play in the system means there is a tiny difference in where the software thinks the laser head is and 

where it actually is. The amount of backlash will, generally, increase as the cutting or engraving speed 

increases. 

When engraving graphics, this difference, as small as it may be, may result in the edge of a graphic 

becoming uneven. To reduce this we add compensation. 

Adding Backlash:  

 

 

 

 

 

 

To change the reverse interval scanning dialogue box (in Figure 62), the user should first click on the 

“Scanning (Reverse Interval)” check-box (in Figure 63), then click on the [Add] button, and set the 

distance and speed needed to modify the reverse block entry clearance.  Set speed and backlash and 

click OK in the dialogue box and the backlash compensation will be applied. To delete a setting, 

highlight the setting and click on the [Del] button. 

To obtain information on the controller and its parameters, the correct password “RD8888” must be 

entered in the dialogue box shown above. 

Figure 61 Figure 60 

Figure 62 Figure 63 
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3.2 System Information 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You will need to have your computer hooked up to the laser, then click on the “Read” button. This will 

read the data from your laser. 

Four of the more important pieces of data related to time are as follows; 

Total on time refers to the total time the controller has been working.  
Total processing time refers to the total time devoted to processing, including rapids.  
Previous processing time is the total time of processing, the last time the program was run. 
Total laser on time refers to the total time the laser has been fired.  

The X Total travel (m) and Y Total travel time (m) are total travel of motors X and Y, respectively, in 

minutes.  

Mainboard version is simply the version of the software installed in the controller. If an upgrade for 

the controller exists, it will be in the form of a *.bin file. After the upgrade, the user must click the 

"Reset" button on the control panel before the controller can be used normally.  

 

 

 

 

Figure 64 
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3.3 User Parameters 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

One must “Read” the board parameters from the Laser before setting the user parameters. To do this, 

Click on "Read" with the USB cable attached to your laser, and with the laser turned on. If you do not 

see the buttons as shown, slide the "Laser Work" panel a bit lower. It is highly recommended that you 

save this file the first time you have “Read” it. The Save button will be enabled once you have read the 

machine settings. See Section 1.6 for the reason to save your original settings. 

3.3.1 Cut Parameters  
The Cut parameters (shown in Figure 65) include provision for setting the following parameters:  

Idle speed: This parameter determines the maximum speed of all laser head movements when the 

laser is not firing during the operation of the machine. This parameter should not be lower than the 

lower of the start speed of the X-axis or the Y-axis, and it should not exceed the higher of the 

maximum speed of the X-axis and the Y-axis. If a setting is set too high, the controller will 

automatically reset the illegal parameter to a value within the permitted range. Although slightly 

higher idling speeds shorten operation time, excessively high idling speeds can cause a 

vibration of the tracks; therefore, you should consider this, along with the additional wear and tear 

to the machine that a very high idle speed causes and take care not to set it too high. 

Figure 65 
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Idle Acc: (acceleration) refers to the acceleration speed of the laser head and point to point speed 

of acceleration while not firing. If the idle acceleration is set too slow, the actual speed may not 

reach the value set for motion; if it is set too fast, the unit may not be able to absorb the resultant 

mechanical vibration, producing jitter. Idle acceleration generally should be set slightly higher than 

of Max Acc (acceleration).  

Start Speed:  Corresponds to the acceleration up to the speed of cutting. This cutting speed is the 

speed set in the layers “Cutting Speed” parameters of the selected layer. 

Min Acc:  The least amount of acceleration when not lasing. 

Max Acc: The maximum speed that the laser can accelerate. If set too high, it can cause the 

stepper motors to loose steps. This is heard as a humming like sound with the head not moving 

when it should be. 

Idle Delay: The amount of delay from the time the machine goes from rest to moving. 

Acc Factor: The amount of global speed setting, as a percentage, to apply to the other settings. To 

lower by a percentage, set to something like 80% to increase set to 120% or your desired amount 

of decrease or increase. 

Go Acc Factor:  The “Go Acceleration factor" is related to boundary cutting speed. The greater the 

ratio, the greater the cutting speed.  

Speed Factor:  The speed of turning around corners will increase as this parameter increases.  

Key Setting: 

 

 

 

 

 

This sets the primary mode of cutting. There are 5 choices; Slow cutting, Precision cutting, General 

cutting, Speed (Fast) cutting and Super speed cutting (Very Fast). Select your primary cutting mode 

and click on “OK” to save or “Cancel” to exit without changes. This will change the speed settings of 

your “Cut parameters”.  

 

 

 

 

 

Figure 66 
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3.3.2 Sweep Parameters (Scan) 
The input screen (shown in Figure 67) sets sweep parameters. The definitions of the parameters in 

the input screen below are as follows:   

 

 

 

 

 

 

x Start Speed and y Start Speed: Used along with the stepper motor drag, the use of x or y start 

speeds allows work to start directly from a non-zero speed to shorten overall processing time.  The 

X and Y axial load is different from each other, the initial speed of the X-Axis should be slightly 

higher than the initial speed of the Y-Axis.  

x Acc, y Acc: The x and y Acc. (acceleration) parameters must be set to match the scanning 

speed (the speed of processing as set in the Layer Parameters). If the x and y Acc. parameters are 

too small, scanning efficiency is negatively affected. The machine can be set to the actual inertia 

load as X and Y Axis loads are much higher than the X-Axis or Y-Axis acceleration loads.  

Line shift speed of scanning: This parameter is used to control the maximum speed at which 

scanning shifts from one line to the next line. This function is used when precise line and/or block 

positioning is required and the line space or the block space is too large. The user can set the line 

shift speed of scanning to a comparatively low value. This parameter cannot be less than the jump-

off speed of the corresponding axis during the line shift, nor can it be higher than the maximum 

speed of the corresponding axis during the line shift. If the setting is illegal, the controller will set 

this parameter within the allowed range.  

Scan mode: Two scanning modes are available, Common Mode and Special Mode. The Common 

Mode does not allow treatment during the scan, while the Special Mode allows the treatment of 

light spots. If the Special Mode is activated, the power of the laser will be increased in such a way 

as to reduce the proportions of light spots. Laser power attenuation will be higher, to achieve the 

same depth of scanning. The purpose of selecting the Special Mode is to make the laser fire high 

power short duration beams. During deep scanning, such beams have the effect of achieving a flat 

bottom effect. If, however, the light spots are improperly adjusted, this effect may not be achieved. 

Using the laser in high power for even a short duration can reduce the service life of the laser. The 

Common Mode is the default. 

Facula Size: (Laser Dot Size) When scanning using the Special Mode, this parameter is used. 

The dot size can be controlled by 50% to 99%.  

Engraving Factor: Controls the speed of engraving, by an entered percentage, on a Scan layer. 

 

Figure 67 
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3.3.3 Home Parameters 
 

 

 

 

 

Home Speed:  This parameter determines how fast the laser head is moved back to the origin. On 

a larger format machine, the speed can be increased slightly. It is machine dependent as it 

increases stresses on the axis drivetrain. 

X, Y, Z, U & Auto home:  These axis can be set as to whether they should be reset at boot time. 

The “Home offset” from “0” is in the Vendor settings.  

3.3.4 Feeding Parameters: - Requires A Feed Source, Like A Belt Table 
 

 

 

 

 

 

Delay Before Feed:  This parameter refers to a pause before material is fed. When it is used in 

combination with the feeding device, the user can allow for such hands-on operations as sorting 

material by setting the delay (in seconds) before feeding to some appropriate value.  

Delay After Feed:  This setting makes the feeding device pause for a specified duration after it has 

moved the material to a designated position. It is invoked whenever a brief period of stability is 

needed before final processing.  

Progressive Feed Repay (replay):  This feature is used when there is some error in the rate at 

which the feeding device moves material line by line.  

Progressive Feed:  A way of feeding the material sent in place of one line.  

Last Feeding: Should the last operation be a feeding operation to move the material out of the 

way? Yes/No. 

 

 

Figure 68 

Figure 69 
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Figure 70 

3.3.5 Go Scale Parameters 
 

Close laser will not fire the laser 
Open laser will fire the laser 
Corner Dot does not seem to do anything 
 

 

 

 

 

These settings are used in conjunction with border-related functions while processing on or near 

the border with independent software. The meanings of the parameters in it are:   

Go Scale Mode: Laser will fire around the border, for opening cut borders and three corner modes, 

Close, Open, Corner & Dot. 

Go Scale Blank:  The moving frame is based on the actual image around all sides. This setting 

adds a space, as entered, to the side of the border in order to ensure the frame completely contains 

the actual graphics. 

3.3.6 Other Parameters 
Array Processing:  There are two options for Graphic (array) processing, Bi-dir (Bi-Directional) 

and S-dir (Single Directional).  

Bi-Directional Array Mode:  cuts the Graphic array back and forth in order;  

Single-Directional Array Mode:  always cutting the Graphic array from one direction to another. If 

Single-Directional mode is selected, all units have the same movement modes and the same 

liquidity of movement, however, this mode will take more time than the Bi-Directional Array mode. 

The default mode is the Bi-Directional Array mode. 

Return Position:  You can select the locating point and the machine origin. This parameter 

decides the position, the locating point or the machine origin, where the laser head stops upon 

completion of each operation. Choices are Origin, Absolute Origin and Not (no) Return. 

Focus Depth:  Auto focus operation to find the correct focus on the material. This setting depends 

on the focal depth of the installed lens. 

Backlash X, Y:  Used to compensate backlash caused by machine drive belt problems. 
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3.3.7 Rotating Parameters 
 

 

 

 

 

 

 

 

 

 

 

You MUST use the “USER” setting tab to enable Rotary Engraving. 

Rotary engraving is only used when the Rotary Axis replaces the Y-Axis.  

The rotary, either the roller or chuck type, plug in and work the same way.  

The Y-Axis is replaced with the Rotary Axis.  

*MAKE SURE THE MACHINE IS TURNED OFF BEFORE PROCEEDING*  

Hardware Rotary Setup Remove the Y-Axis connector. Then plug in the rotary’s 4-pin female 

connector in place of the Y-Axis connector. The location will vary by machine model. Some 

connectors are even inside by the controller.  

Important! If the image looks mirrored vertically/horizontally, move the motor side of the rotary to 

the opposite side of the table by rotating the rotary 180 degrees. Now turn the machine on and let 

the laser head return to the home position. Since you unplugged the Y-Axis connector and replaced 

it with the Rotary attachment, you’ll notice that the laser head will only go to the left (or right 

depending on your heads home position) until it hits the X-Axis limit switch. This is normal and what 

it should be doing. After the laser head has moved all the way to the to the normal X-Axis home 

position, and stopped, move & push the gantry all the way to the back of the machine so that the Y-

Axis limit switch has been triggered. Doing so, the rotary is correctly adjusted with the 

corresponding coordinates of your worktable and now should be ready to be used. You can now 

move the head to position it over the item to be engraved on the rotary. Before continuing to the 

software portion of the setup, make sure the USB cable is connected between the laser and the PC 

& that the laser is turned on. 

 

Figure 71 
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3.3.7.1 Software Chuck Rotary Setup 
Open RDWorks (if you haven't already) and locate the User tab on the right side of the software. 

Click on the Read button below and if the machine and PC are connected correctly, a 100% 

status bar should appear. Figure 71 shows where to enable the rotary and input your circle 

pulse. The circle pulse is the number of pulses it takes to turn the Chuck a full 360 degrees. 

NOTE: The Circle Pulse does NOT work with all versions of Controller software. 

Quick test is to move your y axis to the home position and draw a line 50 mm long in the y axis. 

Click on Read in the User Settings, enable Rotary. Set your “Circle Pulse” to 5000. Write this 

setting and do a frame. Note where the y axis moves to. Then change the Circle Pulse to 10000, 

Write, then do the test again. If the y axis moves to a different spot, then the Circle Pulse WILL 

work on your machine. If not, you will have to do it using method #2, described after the Circle 

Pulse Method. 

For a test, the “Circle pulse” can be one of these common numbers. They are 400, 800, 1000, 

1600, 2000, 3200, 4000, 5000, 6400, 8000, 10000, 12800, 20000, 25000 and 25600. If you 

know what the stepper controller for your Y-axis is set to, that is the number to use. Most drivers 

will have switch settings printed on the face of the case. Then one must multiply by the gear 

ratio.  One must take into account the gearing that is specific for your chuck. Count the number 

of teeth on both pulleys. Divide the Chuck Pulley (A) Number by the Stepper Pulley (B) Number. 

Then multiply the Controller Stepper rate by the pulley result. Example: Stepper pulley has 24 

teeth, Chuck pulley has 48 teeth and the Controller has a rate of 8000. The result would be 

(48/24 = 2) * 8000 = 16000. In this case, the number (16000) is the number to put into the “Circle 

Pulse” setting. 

To test this, draw a box with a Y dimension the same size as your chuck circumference. Place 

masking tape on the chuck when it is at a zero position. Then do a frame or a Test. It should 

rotate to that mark. If it goes past the mark, the numbers are too low. If it doesn't make it to the 

mark, the numbers are too high. 

To setup the Chuck Rotary, the Diameter (mm) will be the only variable that will be changed 

depending on the diameter of your material. Now measure the diameter of your material and 

input that number, in millimeters, in the Diameter box as shown in Figure 71.  

For all machines using this method, the circle pulse will always be set to the number that you 

have determined to be correct and once figured out, it should never be changed when using 

the Chuck rotary. Only the Diameter (mm) should be changed. Input the correct diameter of 

the object to be engraved, then click on the Write button. This must be done every time you 

change any values in the User Tab. Again, before running your job using the Chuck rotary, 

make sure that the curvature of the material is leveled on the Chuck rotary and that the 

autofocus is aligned at the peak (top-most surface) of your material. Just be very cautious when 

using the Frame (test box) when using the Chuck rotary so that the laser head and/or the 

autofocus pen will not ram into the material or the motor of the rotary.  
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Method #2: This is another method of adjusting for the Chuck style Rotary. 

Determine the length of a vertical line that will drive the rotary 360 degrees.  

This will take some experimentation. One might start with a number of 50 mm and work either 

higher or lower until there is a full 360 degree rotation of the chuck. Let’s say for an example that 

the number turns out to be 48 mm. Calculate a vertical scale factor as 100 x 48 / (π x D) where 

π is 3.1415926535 and D is the diameter of the work piece. This would then be: 

100 x 48 = 4800 / 3.1415926535 = 1527.88745 which we will round to 1527. 89 / D 

For each work piece diameter, calculate the scale factor as 1527.89 / D for your machine.  Once 

the graphic is in RDWorks, make sure the aspect ratio lock is off and then scale the Y-

dimension by the calculated percentage. If for example the work piece Diameter was 40 mm the 

scaled result for the Y axis would be 1527.89 / 40 = 38.197, so you would scale the Y axis by 

38.197%. Then, send the job to the machine.  

Adjusting Frame/Test Speed:  

*The following method works for both Chuck & Roller Rotaries* For best practice, always 

frame on your image (by pressing the FRAME button on your LED Control Panel or by using the 

“Test” button in the user panel) on the material by making sure the image is going to engrave/cut 

correctly whether on the roller or chuck rotary. The default testing speed when framing is 50 

mm/s. For the roller rotary, this will be problematic because at this speed, your material will more 

than likely "fly off" your roller rotary, so you will need to reduce this speed (recommendation: 5-

30 mm/s).  

 

 

 

 

If adjusting for the “Chuck” style rotary, click on the “Test” in Figure 71 and a dialogue box like 

Figure 72 will appear. Set your desired speed. Adjust the speed to where your material will not 

fall off the rotary, press “OK” and the rotary will turn to the bottom of the object. 

3.3.7.2 Small Roller Rotary Setup 
Setting up the small roller rotary is MUCH LESS complicated: 

Russ Sadler's Method of Rotary Engraving/Cutting – Calculation 

Videos on this process are at: 

https://www.youtube.com/watch?v=wyevrQXaGRo 
https://www.youtube.com/watch?v=sIlXSZhgbe4 

Russ has a nice method of calculating the numbers for use with rotary engraving/ cutting using 

the small rollers. 

Figure 72 
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This method involves a large diameter tube. Measure the circumference around the tube (mm 

works best). Place the tube in the chuck or on the rollers. Now, in RDWorks, draw a line that is 

the same distance as the circumference. Place Lines at each end, one up and the other down. 

Set your power to a value for light engraving on paper with a speed of 30 mm/s. Now, rotate the 

graphic line by 90 degrees. 

Save and then Load the designed program in to the machine. Do a frame, then when all is set 

properly, start engraving. Once completed, very carefully, measure the length of the engraved 

line (actual distance travelled).  

Now for some simple math. Take the “Circumference of the tube / Actual distance traveled”. So, 

if the tube was 150 circumference and the actual distance was 209, we would divide 150 by 209 

and get .717703 (x 100) = 71.7703. This is our Magic Number. We would now Scale the 

drawing by 71.7703 in the Y direction once the graphic has been rotated. Do not scale the X 

axis, although you can if the graphic has not yet been rotated, but then you must rotate the 

graphic before cutting. Should you desire to return the graphic to the original size we would use 

the reciprocal 1/X function (of .717703) on our calculator and get 1.3933333 (x 100) = 139.333 

and scale the graphic in the Y (or previously scaled) direction. 

 

3.3.8 Wireless Panel 
 

 

 

 

 

These settings are used with the wireless control panel, if installed. This allows “Wireless” LCD 

function control. It is an option available from Ruida.  

See http://rdworkslab.com/viewtopic.php?f=17&t=403 

Set to “Yes” to enable speed shifting (allows slow and regular movement speeds) to the settings 

below it. 

Figure 73 
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3.4 Document Management 
 

 

 

 

 

 

 

 

 

The functions of the features listed in this object are as follows:   

Read:  

The list of files on the controller can be read by clicking the “Read” button. File information will be 

displayed for the documents in the list.  

Download: Clicking on the “Download” button results in download of any number of files in the 

dialogue box to the controller. All files may be selected by entering the * wild card for the 

file name while specifying .rd as the file type. If the download is successful, the document 

list will update.  

Process: Select the file to be processed from the document list, and click the Process button. The 

controller will start the specified document. 

Delete: To delete a specific file, select it and click the Delete button. The controller will delete the 

specified document. If the deletion is successful, the document list will be updated.  

Delete All: This button removes all files in the controller and then updates the document list.  

Cal time: The controller supports processing files in terms of the time spent applying them in laser 

operations. The number of hours already spent in applying a particular file can be 

calculated and displayed by selecting the file and then clicking the “Cal time” button. The 

user must remember to click the “Read” button to display the results of these 

calculations.  

Upload: The user should click the “Upload” button at the bottom right to select offline files and 

save them to the computer.  

Figure 74 
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4 Chapter 4 Processing Output 
This chapter describes operation of the Process Control Bar, parts of the System Work Platform, and 

the Vendor Parameters menu. 

 

 

Processing control 

 

 

Layer settings 

 

 

Search device 
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Figure 76 

Cop
yr

igh
t 2

01
6 

RDW
or

ks
lab

.co
m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d



This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 71 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

4.1 Search Device 
 

 

 

 

 

 

 

 

Device Ports: 

Many of the functions of RDWorks depend on the program communicating with a controller. The 

computer may be connected to one or more controllers via USB or Ethernet.  

The first controller connected via USB can be detected automatically. Any other USB-connected 

controllers and all Ethernet connected controllers must be added manually.  

To add a controller: click Port Setting, then Add. Enter the details of the controller to be added in the 

ensuing dialog. The port can be tested at this point to ensure that the controller is responding properly. 

If a change is needed controller details can be Modified or Deleted. The controller which is to be 

communicated with is selected from the drop-down list to the right of the Port Setting button. 

 

 

 

 

 

 

 

 

 

 

Figure 77 
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4.2 Layer Processing 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Layer reorder: click on a colored layer and you can change the order of layers by using the mouse to 

drag the layer up or down to the specified location. 

To use these settings, you must check the “Path optimize” option. Note: Regardless of the order you 

set the layers, scan layers will ALWAYS be processed before cut layers. It is wise to check the cutting 

order with the preview button before you save your file. 

4.3 Position  
The drop-down selects the start point that the laser head will move to before processing begins. The 

Origin will be set to that point. In all cases after processing completes or is aborted the laser head will 

return to the point specified in the User parameters. 

Current Position: starts the job without moving the laser head. 

Anchor Point: returns the head to the origin before starting the job. Note that any of the other options 

here will set the origin to the point at which it starts, so this option is only really effective if none of the 

others have been used since the user set the origin. 

Machine Zero: starts the job from the zero position of the machine. 

Figure 79 
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Absolute Coordinate: starts the job at the coordinate of the drawing on the computer. 

Note: the behaviors are different if the files are retrieved from machine memory at a later time. Only 

files with Absolute Coordinate will behave as above, all others will start from the Origin defined on the 

machine at the time.  

 

 

 

 

 

 

 

 

4.4 Go Scale / Cut Scale 
Go Scale: the button causes the laser head to move in a rectangle around the area of the drawing. A 

dialog prompts the user to set the speed of movement and the width of blank space around the 

drawing. Click the “Go Scale” button and the laser head will run along the rectangle (perimeter). 

Cut Scale: the button does the same but with the laser active, thus cutting the rectangle. The dialog 

for Cut Scale also prompts for Minimum and Maximum Laser Power to be used. Click the “Cut Scale” 

button and the laser head will cut along the rectangle (perimeter). 

 

 

 

 

4.5 Laser Work - Start/Pause/Stop/Save to UFile/UFile Output/Download  
The functions of these buttons are as follows: 

 

 

 

 

 

 

Figure 80 

Figure 81 

Figure 82 
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4.5.1 Start  
The Start button sends the current drawing to the machine and the machine processes it. 

4.5.2 Pause\Continue  
This button pauses the machine operation. Clicking a second time continues from where it was 

paused. This button is effective even if the job is started from the control panel. 

4.5.3 Stop  
This button stops the current process at the machine. The job is aborted. This button is effective 

even if the job was started from the control panel. 

4.5.4 Save To UFile  
The current drawing is saved to disk in RD format. The file may be transferred to the laser machine 

on a USB stick. A dialog allows the user to assign a name to the file, it is recommended that file 

names are 8 characters or less since the controller is restricted to 8 character file names. 

4.5.5 UFile Output  
A RD file is selected via a dialog box and is transferred to the machine which processes it 

immediately. After saving a file offline, click Ufile Output to select the RD file for processing.  

4.5.6 Download  
The current drawing will be transferred to the machine. A dialog lets the user assign an 8 character 

name to the file on the machine. If the file exists on the machine you will be asked if you wish to 

overwrite that file. 

4.6 Output  
Select graphics when the “Output Select Graphics” checkbox is checked, only those parts of the 

drawing which are selected will be output. If nothing is selected, nothing will be output. If the “Selected 

Graphics Position” checkbox is checked, the Laser Head Position will be relative to the selected parts 

of the drawing, if it is not checked the Laser Head Position will be relative to the entire drawing. 

4.7 Path Optimize 
Clicking this button optimizes the path automatically before a file is output. If the file path does not 

need optimization or has already been optimized, this button should not be clicked because it 

increases waiting time.  
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4.8 Test 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

In the Test tab of the System Work Platform, the user can read the current position of the Laser Head 

using the Current Position button.  

The laser head can be moved using the X+, Y+, X- and Y- buttons. The Z and U axes, if fitted, can be 

moved by the appropriate buttons. The Home buttons will return the laser head or axis to the Home 

position. It should be noted that only one axis can be controlled at a time with the exception of “Home”. 

The amount and speed of movement are governed by the Offset and Speed input fields.  

If the Move From Origin check box is ticked, the endpoint will move to a point relative to the Machine 

Home position, otherwise it moves relative to the current position. If the “If Light” check box is ticked, 

the laser will be turned on during the movement at a power selected by the Power input field. 

Move From Origin example:  If Move from origin is checked, and the step distance (Offset) is 10mm, 

the head will move to 10mm from machine zero. It's not possible to input negative values in Offset, so 

it never gets to the controller. 

The time taken by the previous job can be read by clicking the Previous Work Time button. 

 

 

 

Figure 83 
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4.9 Output Setting 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.9.1 Feed Setting 
To use the feed setting, the feed must first be enabled. After setting parameters for machine 

feeding, the shaft repeatedly feeds a specified length of material until the specified number of 

feeding events reaches the total number set. If the machine is not equipped with feeding devices, 

the “Enable feeding” box should not be checked.  

4.9.2 Backlash Repeat Optimization 
If the machine’s belt tension causes the edge of the scanned graphic to become uneven, the 

backlash should be increased. There is a specific relationship between a particular speed and a 

particular backlash setting but, in general, the greater the speed the greater the backlash setting. 

Check this box if optimization is desired. 

A note on belt tension from the forum by Abraham Saenz:  

1. Excessive belt tension can cause premature bearing failure increase noise and resonance. 

2. Optimal belt tension can actually be used in your favor to help reduce the transmission of stepper 

motor resonance and noise.  

3. Sub optimal belt tension can produce much undesired backlash.  
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4.9.3 Laser Head 2 Offset - The Two Headed Laser! 
In machines with two laser tubes, any mechanical offset can be compensated for by entering the 

amount of offset here.  This generally is used with two different power laser tubes in a machine 

because the two laser tube powers can be used for different functions. In some machines equipped 

with two different powered laser tubes one is responsible for cutting and the other is responsible for 

engraving. 

4.9.4 RDWorks Rotary Setup  
Clicking [Enable rotate engrave] is no longer enabled using this dialogue box.  

See Section 3.3.7. 

4.10 Layer Settings: 
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4.10.1 Position Setting 
 
 
 

 

 

 

 

 

 This Icon will change the starting position of the array. Each click will move it to a different 

corner. 

This function, controlled by the input screen shown in Figure 86 and Figure 87, makes it possible 

to instruct the machine to process a virtual array of a graphic object without the need to create 

actual copies in the graphic workspace. The function is similar to the Object Array Replication 

command discussed in Section 2.9.5. The meanings and functions of the options in the control 

panel are as follows:  

There are two ways to use this function.  First it can be used to produce a user specified number of 

rows and columns of a selected object.  Second, it can calculate for the user the number of rows 

and columns of selected object that will fit within a user specified space.  

In the first case, a user enters the desired number of X columns and Y rows of the object, any 

desired spacing between objects in the rows or columns, and any desired offset (i.e. shifting of 

alternating rows or columns).  The rows and columns may also be alternately mirrored both 

horizontally and vertically by selecting the mirror check boxes.  These settings, combined with 

rotating the object using one of the rotate commands described previously can be used to efficiently 

pack the virtual array for maximum yield.  Once these settings are made, clicking on Virtual array 

will display the virtual array layout as it will be processed. 

Alternatively, to have RDWorks calculate the number of rows and columns to fit a specific space, 

select Bestrew (Distribute). This invokes a pop-up in which the user enters the dimension of the 

space.  When OK is clicked, the X and Y numbers are calculated by RDWorks and automatically 

input into the virtual array settings.  The user may further set Space, Offset, and Mirror as 

described above.  The array is then created by selecting Virtual array. 

 

 

 

 

 

 

Figure 86 Figure 87 

Figure 88 
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By selecting Adjust, the Space and Offset can be adjusted by button clicks that apply the specified 

adjustment and the result can be observed graphically as the adjustment is made. 

There are two ways to use this function. First it can be used to produce a user specified number of 

rows and columns of a selected object. Second, it can calculate for the user the number of rows 

and columns of selected object that will fit within a user specified space.   

In the first case, a user enters the desired number of X columns and Y rows of the object, any 

desired spacing between objects in the rows or columns, and any desired offset (i.e. shifting of 

alternating rows or columns). The rows and columns may also be alternately mirrored both 

horizontally and vertically by selecting the mirror check boxes.  These settings, combined with 

rotating the object using one of the rotate commands described previously can be used to efficiently 

pack the virtual array for maximum yield. Once these settings are made, clicking on Virtual array 

will display the virtual array layout as it will be processed. 

Alternatively, to have RDWorks calculate the number of rows and columns to fit a specific space, 

select Bestrew (Distribute). This invokes a pop-up in which the user enters the dimension of the 

space.  When OK is clicked, the X and Y numbers are calculated by RDWorks and automatically 

input into the virtual array settings.  The user may further set Space, Offset, and Mirror as 

described above.  The array is then created by selecting Virtual array. 

By selecting Adjust, the Space and Offset can be adjusted by button clicks that apply the specified 

adjustment and the result observed graphically as the adjustment is made. 

4.10.2 Setting Laser Cut Parameters 
The input panel for setting laser scanning parameters (in Figure 89) is brought up by double 

clicking on the colored layer in the Work tab in the layer settings. Clicking the Parameter Library 

button brings up the Parameter Library dialog (in Figure 90). The parameters of the current layer 

may be saved with a name and description, and previously saved parameter sets may be selected 

and loaded into the current layer. 
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               FIGURE 90     

   

            

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
To edit something in the layer list, invoke the layer parameter dialogue box (illustrated in Figure 89 

& 90) by clicking on the layer color. The layer parameters are divided into two parts: public layer 

parameters and proprietary layer parameters. Public layer parameters are effective regardless of 

how the layers are processed. Proprietary layer parameters point to the layer of processing type. 

Change and the corresponding parameters will also be changed.  

Clicking ungroup seems to release the virtual array so they can be processed. 

Layer: Graphic objects may be assigned to differently colored layers. Each layer can have different 

processing parameters. 

Is Output: This parameter has two settings, Yes and No. If set to Yes, the corresponding layer will 

be output. A No setting will result in the layer not being processed. A useful feature of “Is Output” = 

NO is best described with a simple example:  

If you draw a 25mm circle on a black cut or scan layer and then draw a 100mm square around it 

that is on a blue cut layer, the green datum dot will sit on the top corner of the blue square. If you 

now make the blue layer “Is Output” = No, the square will not cut but the origin point where the 

Figure 89 

Figure 90 
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head will start and stop from will remain at the corner of the blue square. This is one of many ways 

to park the head away from the job after cutting to facilitate easy removal of work 

Speed: Note that when a smooth cut is paramount, slower processing (and possibly lower power) 

should be used; faster processing causes the trajectory of the cut to be more erratic. Slower speed 

will allow deeper cutting for a selected power setting. Faster speed distributes less energy into the 

cut area. Note: If the “Default” LCD box is checked, the speed set on the Control Panel on your 

machine will be the speed at which the file is run. 

Recommended Maximum Scan Speeds will vary depending on your machine mechanics and will 

vary from 350 mm/s to 900 mm/s and possibly higher. Smoother cuts are created by moving 

slower. Depending on what you are doing regardless of whether the Mode is set to Scan, Cut, or 

Dot, speeds may be usefully set from 1mm/s to the machine maximum setting. 

Is Blowing: This setting controls whether the external air supply is operating. If it is enabled, by 

selecting it, then this layer setting will allow it to blow on the work. This setting only works if the 

machine has a solenoid to control air flow. This feature seems illogical because whenever the laser 

beam is on you MUST always pass air through the nozzle to prevent "fogging" of the lens with 

fumes/smoke. Therefore there are NO circumstances when you would choose NO. 

What you do need is a valve to regulate the air assist flow for different materials.  

Processing Mode: This setting controls how the corresponding layer is processed. If the current 

layer is a vector layer, it then includes four choices: Scan = Engraving, Cut = Cutting, Dot = Dotting 

and Pen. If the current layer is a BMP layer (bitmap image), only the Scan mode is available.  

Clicking on the Advance button will bring up the dialog for, Other Layer Parameters: 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 91 
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Min Power-Max Power: These settings corresponding to the controller laser signals 1 through 4. 

Note that laser 2 – 4 settings are meaningless if your machine only has one laser tube.  

Minimum power and maximum power: The power of the values range from 0 to 100, with 100 

being maximum laser power and 0 being minimum. When Scanning a Bitmap, the values should be 

in a range to allow changes in the depth of cut depending on the black levels in the bitmap. Note: If 

the “Default” LCD box is checked, the Min. & Max. power set on the Control Panel on your machine 

will be the power at which the file is run and will override your programmed values. 

The idea of these settings is that they can be set DIFFERENTLY when CUTTING so that at the 

machine speed changes the power will scale to prevent too much power in the slow sections. That 

is, if both are set the same during cutting, then in corners, tight curves, and the ends of lines as the 

machine slows down the material will be over processed.  I believe the correct procedure is to run a 

job with the max and min set the same.  Continue testing and adjusting power until the fastest 

travel speed areas are cut the way you want.  Then, if necessary, reduce the min power setting 

until the slow travel speed areas are cut the way you want. 

Pen up and down: If the machine includes a lift platform, this function can be enabled to set a 

different platform height during processing. This function enables the write position to be set to a 

level such that the auto focus sensor will not interfere with processing of the work piece. If it can be 

determined that there is no problem with the processing of the work piece, there is no need to 

adjust the pen position. This setting may also be used to de-focus the beam to create wood burning 

or possibly laser origami. 

Seal: Closed cutting graphics does not require the use of sealing compensation, but un-closed 

graphics can be closed by means of it. If, however, the sealing is misplaced, there will be no 

compensation. Enter a distance, in the seal box, that if the un-closed distance is less than, then 

sealing is desired. Seal defines the overlap of beginning & end of the cut. 

Sew Compensation (Kerf Settings): A kerf is the width of the cut made by the laser. By default 

RDWorks cuts along the center of the path. This will result in outside cuts being smaller, and inside 

cuts being larger. The kerf settings allow you to correct for this. RDWorks calls the Kerf setting 

“Sew Compensation”. It is found in the cutting parameter window under the Advance button.  
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You will need to tell RDWorks if a path is an outside or inside cut. You will also need to have the 

“Cut In/Out Bar” enabled to set the directions. You can set paths manually or use the auto button. 

The Auto button works if you select multiple paths. It will set all inner paths as “In Cut” and outer 

paths as “Out Cut”. To set a path manually, highlight the path and select the offset direction from 

the drop down menu.  

 

 

 

 

 

 

 

 
Open Delay: Open Delay MUST be used with Laser Through Mode to hold the beam still at the 

start of EVERY new cut in the program. The power of that cut is defined separately, after which the 

beam power reverts to the programmed power and the program commences. Its main use is for 

when more powerful machines are cutting metal, therefore Through power will rarely be required 

for non-metals.  

If you do not use Through Power, this open delay will still operate and will delay the start of "beam 

on". Your program will start but the beam will not and you will get an uncut section at the beginning 

of your program. 

Figure 92 

Figure 93 
Figure 94 

Figure 95 
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Close Delay: Close Delay defines a period of time at the end of the cut before the Laser is 

deactivated. 

Laser through mode: See Open Delay. 

Through power: Through power defines the power at which the laser will fire in Through Mode if 

Laser Through Mode is checked and Open Delay is non-zero. 

Other layer parameters can be found by clicking on the advance button by the “Processing” mode.  

4.10.3 Setting Laser Scan Parameters: 
 

 

 

 

 

 

 

 

 

 

 

 
Figure 96 illustrates the Layer Parameter pop-up as it appears when a vector object layer is 

selected and Processing Mode is set to Scan. 

Figure 97 illustrates the Layer Parameter pop-up as it appears when a bitmap object layer is 

selected and Processing Mode is set to Scan. 

Negative Engrave: flips Black & White. Used with dark materials to make the etching show. 

Ramp Effect: gives the effect of a 3D cut as if a V-Bit had been used. 

Independent Output: cuts one object or letter at a time. 

Vector Scan: does not support certain functions. In Figure 96 the unsupported ones are grayed 

out. 

Bitmap Scan: supports all except for Ramp Effect and the Engrave Circle handle functions that are 

grayed out in Figure 97. 

Optimized scanning: Choose optimized scanning to automatically adjust the scan to the scanning 

interval for best effect. Otherwise, the user settings of the scanning interval scan pattern are 

applied. It is generally advisable to choose "optimal scanning." 

 

Figure 96 
Figure 97 
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Output direct: (Grayscale Bitmap) As referred to the image, higher power will be associated with 

deep/dark colors, on the other hand, for shallow/light colors will have lower power outputs. This 

works fine for glass and clear acrylic, however if you want to put an image onto slate for example 

you might need to check “Negative Engrave”. 

Scan mode: There are four different scanning modes: X_unilateralism, X_swing, Y_unilateralism 

and Y_swing. 

X_unilateralism: The scanning pattern of a back and forth motion in a horizontal direction, in which 

the laser is firing from left to right OR right to left (uni-directional).  

X_swing: Refers to the optical horizontal direction in the back and forth scanning of graphics, in 

which the laser is firing from left to right AND right to left (bi-directional).  

Y_unilateralism: The scanning pattern of a back and forth motion in a vertical direction, in which 

the laser is firing from up and down OR down and up (uni-directional). 

Y_swing: Refers to the optical vertical direction in the back and forth scanning of graphics, in which 

the laser is firing from up and down AND down and up (bi-directional).  

Overstriking: If not set to Un-process, there are a choice of two methods, Intaglio and Relief.  

Relief cutting is where the letters or object is cut around and appears to be raised, frequently used 

to make rubber stamps. Intaglio is the opposite of relief cutting. Select the desired method. Relief 

requires a bounding area be defined. 

Interval (mm): Refers to the spacing of scan lines. The smaller the number the closer the scan 

lines. 

Suggestions: For vector layers (i.e. color layers), the scanning interval should be set to 0.1 mm or 

less. For a BMP layer, the scanning interval should be set to 0.1 mm or above. Then change the 

maximum power and the minimum power to achieve the ideal effect.  
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4.10.4 Laser Dot Parameters Setting  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

This function is useful for making dot type perforations. 

Dot Time: specifies how long the laser will be fired for a dot if the Dot Length is zero. 

Dot Interval: specifies the distance from the start of one dot to the start of the next. 

Dot Length: specifies the length of each dot. If this is zero, the laser will be fired for Dot Time 

without moving. If it is non-zero, the laser head will move at the speed specified. 

Center Dot: if checked, a single dot will be made at the center of every item on the layer. 

 

 

 

 

 

 

 

 

Figure 98 
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4.11 Vendor settings 
Click menu [File] -> [Vendor Settings] to invoke the Vendor Settings Password Dialog. The vendor and 

machine settings are located here. When the password dialog pops up, Enter RD8888 and click OK. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Click on menu [File] -> [Vendor Settings] to invoke the Vendor Settings Password Dialog. The vendor 

and machine settings are located here. When the password dialog pops up, Enter RD8888 and click 

OK. 

IMPORTANT: Before changing any settings, make a backup. With the machine connected to the 

computer and turned on, select “Read” to read the settings from the laser control board to RDWorks. 

Next, select “Save” to save a copy to a safe location on your computer or an external source such as 

USB drive or optical disc. This backup is critical if you need to restore your settings. 

4.11.1 Motor Parameters 
Motor - These settings “Should” have been set correctly by the machine manufacturer or your 

dealer. Each axis is setup separately. The X axis is the side to side axis. The Y axis is the front to 

the back axis. Z is the up and down axis and will be setup if you have an autofocus motorized 

platform. It may also be used with some manual up and down systems. U may be used for a 

dedicated rotary axis or for a feed mechanism. The “Breadth” (Width) setting is the axis length. For 

the X axis, it is the machine cutting distance from side to side. For the Y axis, it is the machine 

cutting distance from back to front. For the Z axis, it is the distance to the lowest part of the table. 

Click on the radio button for the desired motor axis. 

Dir Polarity: determines the direction of movement and depends on the location of the machine 

origin. It should be set so that the laser head moves toward the machine origin at reset. More 

precise detail cannot be given - -ve/+ve could be in either direction depending how the motors are 

wired. 

Figure 99 
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Limiter Polarity:  must be set according to whether the Limit switch goes low (negative) or high 

(positive) when triggered. 

Breadth: is the amount of movement available for this axis. The controller will not move the axis 

beyond this distance. Set to your machine size in each axis. 

Home Offset: is the distance from the limit switch of the 0 point of this axis. It should be in the 

range 0-5mm. If Hard Limit Protection is set for this axis, Home offset should not be less than 2mm 

to prevent emergency stop of the axis if the hard limit is triggered wrongly. A non-zero Home Offset 

CANNOT be used to prevent the “No enough extend space” error. The space between the machine 

zero and the Home Offset position is 'dead space'. 

Control Mode: may be “Pulse + Direction” or “Double PWM”, and must be set according to the 

motor drivers in use. Default is “Pulse + Direction”. 

Step Length: is the distance moved on this axis for one step of the motor. This can be calculated 

automatically, by cutting a shape of known dimensions and measuring the actual size of the shape. 

Press the ellipsis button (…) and enter the drawn (graph length) dimension and the measured 

(measuring length) dimension and press OK. The Step length will be calculated. X & Y will be close 

to the same, and Z will usually be different. 

Enable Limit Trigger: is checked to enable Hard Limit (Limit Switch) Protection on this axis.  

PWM Rising Edge Effective: must be set according to whether the Rising or Falling edge of the 

motor driver pulse is effective. 

Enable Home: should be set if this axis is actually configured in the machine. If it is not checked, 

the controller will not attempt to return this axis to the home position at reset. This is also set in user 

Parameters. 

Jump Off Speed: is the initial speed of this axis. If it is set too fast, the motion may be irregular. 

Typical values such as 5 - 30 mm/s. 

Max Speed: is the maximum speed for this axis. Typical values such as 200 - 900 mm/s. 

Max Acc: is the maximum acceleration rate allowed for this axis. If it is set too high, the motion may 

be irregular. If too low, it will adversely affect the time taken to complete jobs. The Y axis has a 

typical setting in the range of 800 - 3000 mm/s2 corresponding depending on inertia of the head. 

The X axis has a typical setting range of 8000 - 20000 mm/s2. 

Estop Acc: is the acceleration rate allowed if the emergency stop is triggered. This value may be 2 

- 3 times the maximum acceleration. 

Keying Jump Off Speed: is the initial speed of this axis when a control panel button is pressed. It 

cannot be higher than Jump Off Speed above. 

Keying Acc: is the acceleration of this axis when operated from the control panel. It cannot be 

higher than Max Acc above. 

Invert Direction: reverses the movement of the axis when the control panel (LCD) key is pressed, 

e.g. to make the right arrow move the laser head to the left. 
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4.11.2 Laser Parameters: 
 

 

 

 

 

 

 

 

 

 

 

 

Laser Config: select the radio button according to how many lasers are installed. 

Laser Mode: must be set according to the type of laser tube(s) installed. 

Laser attenuation: causes the head to move more slowly as it is increased from zero. This is for a 

laser that is down on power. 

Show Laser power supply info: has no effect that has been seen. 

Min Power: is the minimum power that will be demanded from the laser. If lower power is set in the 

Layer Parameters or on the Control Panel, the actual output will be increased to this level. 

Max Power: is the maximum power that will be demanded from the laser. If higher power is set in 

the Layer Parameters or on the Control Panel, the actual output will be decreased to this level. 

Laser Freq: is the PWM Control signal frequency for the tube, typically 20 KHz for glass tubes and 

5 KHz for RF Tubes. 

Pre-ignition Frequency: is required only for RF tubes with pre-ignition. 

Pre-ignition Pulse: is required only for RF tubes with pre-ignition. 

Signal Level: is required only for glass tubes and must be set to the input level required – either 

low or high. 

Water Protect: should be checked if a water flow sensor (or other cooling system) signal is input to 

the controller. If the signal is not detected the machine will be stopped. If no sensor is fitted this 

should be un-checked. 

Figure 100 – Laser Parameters 
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4.11.3 Other Vendor Parameters 
There are several parameters that allow setting the Machine type as well as adjusting the 

Transmission mode, Feed mode and Broken Delay and selecting what the Z function does.  

 

 

 

 

 

 

 

 

 

 

 

 

Other Parameters (Figure 101):  

Machine Type: should usually be Normal unless you know better. 

Transmission Mode: should usually be Belt Stepping Type, other modes have slightly different 

control algorithms. 

Feeding Mode: should be set according to the type of material feeding system fitted.  This 

parameter is only valid if the Z Function is set to “Drive for Feeding Axes”. If this is Bidirectional, 

settings in the Z axis motor parameters control how the feed system works.  

Broken Delay: The controller can continue operation when power is restored after an interruption. 

Broken Delay allows adjustment of the position from which it will resume and should be set to 

minimize the gap or overlap in the cut or engraving. 

Z Function: defines the purpose of the Z Axis. It may be used as a rise-fall platform or as a 

material feed. 

Enable Protect: should be unchecked if no lid or cover interlocks are fitted to the machine. If 

interlocks are fitted, check this to prevent the machine being operated with the lid open. 

Enable Blower: should be checked to allow the 'If Blowing' parameter of each layer to control the 

air assist function. This would require a relay if one is not installed. 

Head Distance: is the distance between the two heads on a dual-headed machine. 

Figure 101 – Other Parameters 
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4.11.4 Clear Info:  
Clicking on this tab will allow parameters to be reset to “0”. When you initially receive the machine, 

it is highly likely that these are random numbers and have no bearing to actual use. It is a good 

idea to reset these to “0” when you first start using the machine. To do this, click on the “Clear info” 

tab and select the items to be cleared. Initially, leave all checked. Then, with the laser power up, 

click on “Execute” and enter “RD8888” again. This will clear all the numbers and reset to “0”. Doing 

so will then allow one to accurately determine use. 
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ADDENDUM 
Item 1. How To Correct X Y Scaling Factor 

If your machine is not cutting the correct size it can be calibrated to be more accurate. Here are the 

steps to take to correct this problem. 

The first step is to power up your laser and connect it to your computer. Place a piece of material that 
you will use for your test cuts on the cutting bed. The bigger the better. If your machine is cutting too 
big, draw a box that is 50mm smaller in both X and Y dimensions. Cut the file. Then, use a metric tape 
measure to measure the actual cut in both the X and Y directions. Be as accurate as possible. 

Now, click on menu, [File] -> [Vendor settings]. Under vendor settings you need to enter the password 
"RD8888"  

First thing you should do is load the settings from your machine, then save a copy of those settings. 
Click on “Read” and once the settings have loaded, click on “Save”, enter a filename and save those 
settings. These will be your default settings, just in case things go wrong and you need to revert back 
to the factory settings. When everything is scaled correctly, you will do this again to “Write” to the laser 
and then “Save” as your backup settings. 

The scale factor is labeled step length. Click on the button with the three dots. 

Enter the length of the box you drew in the graph length. And enter the actual length of your test cut 
under measuring length. Click on “Ok”. 

The Y axis is next, you will need to click on the Y radio button, 
followed by the step length button. 

Repeat the steps for the depth - height of your test cut. 

Now you can save your corrected settings, and write them to the 

machine.  

Follow up with another test cut and do again if needed. Once you 

have the correct scale settings, WRITE, READ and SAVE these 

settings as your backup. 

 

Figure 102 

Figure 103 
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Item 2. Cutting Multiple Passes 
In looking for a way to generate multiple passes, it occurred to me that using the feed parameters 

might work. I just verified that enabling feeding and entering a count greater than 1 will process the file 

multiple times. Note, I do not have a feeder on my machine, I am just using this software feature to get 

what I want. For example, when cutting foam board, I find I get an excellent cut if I run at 11% power 

and 3 or 4 passes. Previously I would wait for the job to finish and manually rerun it. This is much 

more convenient. 

Setting the distance to 0 speeds up the recycle time. 

Item 3. Fixing Circles That Are Not Round 
You may need to make adjustments for the backlash. The setting is located under the "User" tab next 

to the "Work" tab in RDworks. If the circles are not quite round with a little flatness to the top and 

bottom of the circles, and possibly the Circles are not closing. Adjust for the Y Backlash under the 

User tab to 0.35mm and that may make your circles round and got rid of the non-closing of the circle. 

If you have flatness on the sides of a circle you will have to adjust the X backlash.  

How to adjust for Backlash.  

(1) Go to the "User" tab on the right side of the screen in RDWorks. Make sure you can see the 

OPEN, SAVE, READ, WRITE buttons at the bottom. 

(2) Click READ and then SAVE button to Save your Original Setting from the machine 

(3) Go down to "Other" in the User Tab: then to Backlash Y (mm) and enter 0.35 mm - You may have 

to adjust this based on your backlash amount. Try using 25.4 mm circles until you get the roundness 

you are looking for. For me it was at 0.35 mm 

(4) After you enter the new value Click WRITE which will write new settings to the machine. Run your 

test circle to see results. If the results are good, then you need to SAVE to your Backup file. 

(5) If your WRITE button is grayed out, you must do a READ to the machine first, then it will allow you 

to write new inputs. 

Item 4. Glass CO2 Laser Tubes Essential Information 
#1. Glass tubes are very inexpensive compared to domestic [USA] tubes - so... there will be trade-offs 

#2. It is important to know what your maximum current should be. This may be exceeded but there will 

be a trade-off on the life span. If you can find the manufacturers site - it should be called out. The 

maximum current allowed may be limited on the High Voltage power supply. At power settings above 

the limitations power output will be flat. If your machine does not have a Milliammeter, you should 

consider adding one. Here is a link to Hytech2K's nice article on adding one to his machine - 

http://rdworkslab.com/viewtopic.php?p=1654 

It is not difficult electrically - see "Inserting a Milliammeter (MA) into the Cathode of the Laser tube to 

measure current", below. 

 

Cop
yr

igh
t 2

01
6 

RDW
or

ks
lab

.co
m

   
   

   
   

 A
ll R

igh
ts 

Res
er

ve
d

http://rdworkslab.com/viewtopic.php?p=1654


This Manual is for RDWorks Version 8.01.19 Version 1.0 November 2016 Page Number: 94 

Copyright 2016   RDWorksLab.com  All rights reserved.  Company use or distribution requires written permission. 

#3. Glass tubes are usually rated at the maximum power it can produce - safe maximum power will be 

about 85% less. Make allowances for this fact of life in the Chinese laser world. 

#4. These tubes are sensitive to heat - if they are not cooled properly, tube life will be short. They can 

be cooled in a variety of ways - from a fish tank circulation pump in a tub of water possibly with ice 

packs added to a 3000 series cooler which is a tank with a radiator and fan and requires a lower 

ambient temperature to cool, to a 5000 (and up) series chiller which is actually a refrigeration unit. 

What you need will be determined by the ambient temperature, the duty cycle you expect and the tube 

life you expect. Whatever you use, the cooling water must be kept clean and I would not use tap 

water.  We suggest using purified water without minerals in it. We do not recommend using anti-freeze 

solutions in the mix. If you need to keep the water from freezing, we suggest using a heater and low 

temperature flow controller. You should also have some way of monitoring the temperature. 

#5. Shelf life of a Glass Laser tube is approximately 12000 hours. Much like a carbon battery, they 

deteriorate over time. Some tubes may have been manufactured over 10000 hours ago. They will not 

last very long. Make allowances for this fact of life in the Chinese laser world. When the tube dies, it is 

an opportunity to replace it with a quality tube such as RECI or EFR. 

Power, Maximum Current, Life & Size. 

Some of the more respected Chinese tube makers have important details on their sites: 

EFR- [tubes, power-supplies and lenses] http://efrlaser.com/2-co2-laser-tube/200477 

Reci- [tubes, power-supplies and mirrors] http://www.recilaser.com/en/index.htm 
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EFR Tube Charts 

 

 

 

RECI Tube 
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Item 5. Inserting A Milliammeter (MA) Into The Cathode Of The Laser Tube To 

Measure Current. 
Lasers that are 100 Watts or less can use a 30 MA meter. More powerful lasers need a meter that is 

>= full amount of current drawn by the tube at maximum power. 

After mounting the meter, a milliammeter is easily inserted by cutting the black wire that runs from the 

output end of the laser. This is usually done at the power supply or close to it. Simply run a wire from 

the +ve terminal of the meter to the wire coming from the laser tube and run a wire from the -ve 

terminal to the power supply or if the wire was cut, the wire that is running to the power supply. All this 

is done with the power turned off and unplugged if you are not well versed in electrical. It is best to 

solder the wire connections and use heat shrink tubing to cover the bare wires. At a minimum, tape 

must be used to cover the bare wires where they are joined. Wire nuts may also be used.  

Test your connections. Set the meter on a piece of cardboard so the terminals are not touching any 

metal, then, turn your laser on, set power to 14% or less and give it a quick pulse. The meter should 

move towards the higher numbers not below 0. If it moves below zero, you need to power down and 

reverse the connections at the meter. Once the meter has been tested, remove power to the laser and 

complete mounting the meter. 

 

 

Output of Laser showing black cathode wire running along the tube, back to the power supply. Cop
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Item 6. OPEN Source Vector Software 

INKSCAPE 
This is the most common one it seems- https://inkscape.org/en/  

At first, I was unable to use Inkscape to create drawings that were enough "cad" like... until I 

discovered that you can add a grid (for example, 1mm grid), and you can make "cusp nodes" be 

attracted to the grid (not just the bounding box of each shape). With this, you can, for example, 

draw a rectangle, convert to path, then "glue" the nodes to the grid to have perfect sizing, and then 

using the path tools (add/remove nodes, node properties, ...) to literally make whatever you want.  

The weak point is you cannot really create "technical" drawing, i.e. Inscape is not very good if you 

want to compute intersections, cut paths along the intersection, draw parallel/perpendicular lines to 

any existing line. But for rectangular box design, this is ok. 

QCAD 
It's a very nice and free CAD solution. Very easy to use and perfect for our small machines. 

http://www.qcad.org/en/ 

GIMP 
Gimp is another freeware program. Available from https://www.gimp.org/  

Item 7. Beam Centering Quick & Dirty  
A couple of methods for beam centering. 

#1 I wasn't sure if the beam was centered in the nozzle. To check it I took some MDF and taped a 

stick of chewing gum nice and flat onto it. Then placed this under the nozzle and raised the bed until 

the nozzle just made an impression in the gum. Then lowered the bed and fired a quick pulse. I found 

my beam was quite off center. A couple of tweaks of the mirror and Voila! Centered beam. Makes it 

quick and easy to check at multiple positions on the bed too. This is so simple I'm sure it must have 

been done before but here it is. 

#2 This is a tool that Gene made a while back to check the centering of the beam in the nozzle 

http://rdworkslab.com/viewtopic.php?f=6&t=520  
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Item 8. Photo Engraving Using Special Scan Mode (Scottthorne23) 
See Section 3.3.2. Go to "USER" settings Tab, then scroll down to "SCAN MODE" and select Special 

mode, then "Write" to controller or else it won't save it 

Process the photo using photo shop.  

• First, resize to desired size then change dpi to 600 or 300. Then change to "Grayscale" then 
select "Diffusion Dither".  

• Then select "Unsharp Mask" to clean up the edges. 
• Then "Sharpen" 
• Last is the Contrast and Brightness to remove any spots in the photo. 

There is an automated process for Photoshop that uses a free script available here: 

http://dogcollarlabor.com/smc/index.html  

We also suggest looking at PhotoGrav. It is US$395 but if you are doing commercial photo engraving, 

it might be a viable option.http://www.photograv.com/aspnet2/  

Item 9. Issues With Your Machine Not Being Able To Read A USB Memory Stick?  
• Format the stick as FAT32. 
• Use "SaveToUFile" This will save it as an RD file not an RLD. Only RD files can be read from a 

stick. 
• Do NOT save your file in a Folder on the stick. 
• You might need to reinstall RDWorks, then start at step 1 again. 

Item 10. Frame Slop Error 
Part of the path is out of the bounds of the table. You may get this error when trying to start a job too 
close to the home position and the start point is in the center of the job. Try moving the head away 
from home by 5 mm in both directions. May also be caused by too much slop in the drive belts. 

Has also been caused by a defective controller board. Check the position of X & Y axis and if 
intermittently the numbers are way out of line, suspect the controller. 
 

Item 11. Device Not Connected Problem 
1. Disable Windows Firewall / Virus Checker 

2. I wanted to connect my desktop machine to the laser - just so I know if my laptop fails I have 

that as a standby but kept getting "Device not connected" when trying to install the USB driver. 

Firewall and Malwarebytes turned off didn't help this time. I did a search for the driver that was 

installed on my laptop and eventually got one from here that worked perfectly. 

http://www.ftdichip.com/Drivers/VCP.htm There are options there for Windows, Mac, Linux etc.  Cop
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Item 12. LAN / Network Problems 
Here are the steps to set it up... 

1. Go to the settings menu on the DSP, go to IP config and choose an empty IP that's your 

network but won't conflict with any other devices, i.e.; 192.168.1.100 and a gateway 

254.254.254.0 

2. Boot up a PC that has RDWorks installed on it and is on the same network, go to the Device 

Settings panel (lower Right) and locate and click on "Port Setting", click add and type in 

whatever you want to name your machine, and in WEB put the IP address you assigned it 

earlier. Click test and it should say "Port Test Success!" 

Item 13. Homemade CerMark™ 
CerMarkTM is a coating that can be applied to metal to allow engraving. Here is a homemade formula 

provided by Pierre Dradin. Mix 1/3 Zinc Powder with 2/3 Molybdenum Trioxide Powder (Molybdenum 

Trioxide), and then add denatured alcohol or other to make it the desired consistency. 

Use proper care when handling these chemicals. 

Item 14. Box Creation Sites: 
Four websites that create box patterns. Each has its own benefits and drawbacks, e.g. symmetry, 

control over size and number of finger joints. 

http://www.makercase.com/ 

http://makeabox.io/ 

http://boxdesigner.connectionlab.org/ 

http://www.templatemaker.nl/  

You can then use this site to convert the .SVG file to DXF format. https://cloudconvert.com/svg-to-dxf 
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